Nach dem Update - Crash com.google.android.gms : Play- Dienste : 5.2.8

? user3871754 @ | Original: StackOverFlow
---

meine Abhängigkeiten :

compile "com.android.support:appcompat-v7:20.+"
compile 'com.google.android.gms:play-services:5.2.08'
compile 'com.android.support:support-v4:21.0.+'

aber trotzdem: Google Play-Dienste nicht mehr aktuell. Erfordert 5208000 fand aber 5089036

Wie ist das möglich ?

AKTUALISIEREN diese Arbeit :

compile 'com.google.android.gms:play-services:5.0.89'

or

compile 'com.google.android.gms:play-services:6.1.11'

or

compile 'com.google.android.gms:play-services:6.+'

---

Top 5 Antwort

1Michele @

Sie müssen aktualisieren Google Play Services von Play Store auf Ihrem Gerät, wenn Sie eine Aktualisierung warten, nicht sehen, bis herauskommt

https://play.google.com/store/apps/details?id=com.google.android.gms

Alternativ Suche auf Google und die neuen apk installiert oder verwenden eine ältere Version 5.0.77 oder 5.0.89 wie

2Jerome Campbell @

Ändern Sie die Google-Play- Service- Version in Ihrem build.gradle auf die Version auf Ihrem Gerät oder Emulator.

compile 'com.google.android.gms:play-services:5.0.89' 
3josacky @

Die Version, die Sie suchen, ist 5.2.08 .

Android Studio automatisch bieten, um sie auf die neue Version aktualisieren. Jedoch aufgrund eines Fehlers fällt es die führende Null in "08", was bedeutet, dass die Abhängigkeit ersetzt mit " 5.2.8 " anstelle von " 5.2.08 ", das nicht funktioniert . Um dies zu beheben, bearbeiten Sie die Abhängigkeit zu statt " 5.2.8 " lesen " 5.2.08 "

This will work:

compile 'com.google.android.gms:play-services:5.2.08'

Quelle : http://tools.android.com/knownissues

4jQwierdy @

Für Menschen, die von diesem Problem leiden, sind aber nicht in der Lage, die andere Arbeit zu machen - mein Problem war, dass ich installiert Google Play 5.2.08 in meinem gradle Datei ( kompilieren ' com.google.android.gms : Play- Dienste : 5.2.08 '), weil 5.0.77 nicht funktioniert .

Ich lud die App auf meinem Handy, und es hat nicht funktioniert ,

Ich hatte die letzte Änderung ( dass ich auf meinem Handy bekommen - Android 4.4.2 ) von Google spielen, so erzählte mir, um zu aktualisieren, nicht geben Sie mir alle Optionen

Ich landete nur benötigen, um meine gradle Datei auf den neuesten kompatiblen Google aktualisieren, in meinem Fall Version 5.0.89 . So finden Sie heraus, welche Version

5friederbluemle @

You can now use

compile 'com.google.android.gms:play-services:6.1.11'