Analysieren von Daten für Android L failed.Unsupported major.minor Version 51.0

? sasu @ | Original: StackOverFlow
---

Nach der Installation von ADT Plugin für Eclipse, habe ich versucht, ein neues Hallo Welt Android App machen .

Aber ich traf mit dem folgenden Fehler, als ich versuchte, eine neue Applikation für Android zu öffnen. Ich bin mit JDK 7.0 und JRE 7.0 arbeiten . Ich arbeitete zunächst mit JDK 6.0, doch traf sich mit dem gleichen Fehler, damit ich es deinstalliert und JDK 7.0 installiert und verändert die Pfadeinstellungen auf.

Der Fehler ist eindeutig :

Laden von Daten für Android L (Vorschau ) ist ein Problem aufgetreten . Analysieren von Daten für Android L failed.Unsupported major.minor Version   51.0 .

Meine Einhaltung Ebenen werden auch JDK nur 1,7 geändert. Und Ich habe auch meine JRE Compliance bis 1,7.

---

Top 5 Antwort

1Sree14 @

Bitte überprüfen Sie die folgenden .

Ensure that you have restarted your system after specifying the path name. You can look for the following icon on your eclipse's layout screen. !( http://i.stack.imgur.com/WoX58.png ) The "20" specifies the android version to use when rendering layouts. Change it and see. Last but not least review your ADT configurations. Hope this helps. 2AJP @

Sie können "lösen" es durch die Deinstallation der Android SDK L mit dem Android SDK Manager.

Nicht zufriedenstellend.

Edit

Ich denke http://stackoverflow.com/a/24566948/539490 effektiv was auf das Gleiche, aber ohne die Deinstallation (statt nur die Auswahl der Version der API, die tatsächlich funktioniert ) .

3Ligen Yao @

Prüfen Sie die JDK-Version . Es muss JDK1.7 sein . JDK 1.6 funktioniert nicht.

4tounaobun @

Löschen Sie einfach Android L -Plattformen. Leiten Sie zu Ihrem Android- SDK-Verzeichnis .

adt - Bundle -mac- x86_64-20140321 / sdk / Plattformen / android -L

löschen Verzeichnis android -L und starten Sie Eclipse .

5Haimanti @

Manchmal kann es sein, nur weil der Compiler Compliance-Niveau ist nicht richtig in Eclipse Java- Compiler-Einstellungen festlegen.

Gehen Sie zu Einstellungen Eclipse unter Java Abschnitt- > zum Compiler und dann in ausgewählten JDK Konformitätsstufe 1,7