Eclipse Juno ADT Plugin NDK Gang entfernt ?

? UnTraDe @ | Original: StackOverFlow
---

Ich kann nicht finden die Möglichkeit, das NDK Pfad auf Eclipse Juno mit dem ADT -Plugin . ( Ich lud gestern der ADT Bundle aus dem Android Website ) .

Jeder sagt, ich sollte es unter Windows zu finden - > Einstellungen -> Android -> NDK aber die Option NDK unter Android einfach nicht vorhanden ist . Vielleicht verändert sie die Lage in der jüngsten Version? Wie auch immer ich kann nicht scheinen, um einen Weg, um das NDK Weg in mein Eclipse- ändern finden.

Bild:  Eclipse Juno ADT Plugin NDK Gang entfernt ?

Ich fühle mich, als würde ich etwas wirklich offensichtlich fehlt hier ...

---

Top 5 Antwort

1user1667823 @

Sie müssen neu installieren das ADT-23.0.4.zip ( Vergessen Sie nicht, wählen Sie die Android Mutterentwicklungswerkzeuge);  http://developer.android.com/sdk/installing/installing-adt.html#Troubleshooting .

You should:

Download ADT-23.0.4.zip. Just re-install. Restart. You will see Eclipse > Window > Android > NDK tag. 2Gabo @

Ich hatte das gleiche Problem, ich weiß nicht, warum, aber die Probleme mit der Eclipse / Juno -Version, so dass ich in der Finsternis Seite der Kepler Version Alle funktioniert prima Herunterladen und Installieren der pluggin von adt, Und .

3frihatt @

Ich vor dem gleichen Problem. Es war ärgerlich, diese paar Stunden verschwenden, aber ich denke, ich herausgefunden. Was ich tat, war ,

Packte die Datei com.android.ide.eclipse.ndk_22.3.0.v201310242005-887826.jar von der älteren ADT -Installation hatte ich, was die NDK Option aus dem Ordner eclipseplugins zeigte .

Umbenannt auf com.android.ide.eclipse.ndk_23.0.2.1259578.jar .

Klebte es in adt-bundle-windows-x86_64-20140702eclipseplugins

Neustart von Eclipse .

Hi NDK!

Ich hoffe, dass dies keine Probleme in der Zukunft führen!

4tryer3000 @

Dieses Problem zu beheben, indem installieren " Developer Tools "

Eclipse - > Hilfe - > Neue Software installieren ... ->

Auswahl: " Android Developer Tools Update Site - https://dl.google.com/android/eclipse/ "

deaktivieren Sie die Option " Kontaktieren Sie alle Update-Sites während der Installation erforderliche Software zu finden " Option

suchen und installieren " Developer Tools "

5tangobravo @

Ich hatte dieses Problem mit der neuesten Eclipse- Luna und dem ADT -Plugin - es trotz sowohl das CDT und Android Mutter Developer Tools Plugins in Eclipse Luna installiert sie nicht arbeiteten, stellte sich heraus .

Der Grund war, dass ich mit dem Apple Java 1.6 (die Java 6 ) und Luna " erfordert " eine Java VM 7 . Keine Warnungen wurden zwar zur Verfügung gestellt! Um es zu lösen, ich installiert die neueste JDK von Oracle, und aktualisiert die Datei eclipse.ini in der Eclipse.app Bündel, indem die 2 Zeilen :

-vm
/Library/Java/JavaVirtualMachines/jdk1.8.0_25.jdk/Contents/Home/bin/java

kurz vor der Linie, die -vmargs ist .

Dann, wenn ich neu gestartet Eclipse CDT korrekt verwendet Eclipse -> Preferences... aufgeführt einige C ++ Einstellungen, die zuvor nicht gab, und die Android Abschnitt hatte eine NDK Eintrag der erlaubt, den Pfad anzugeben .