Der Versuch, zu aktualisieren ADT - Empfang " widersprüchliche Abhängigkeit" Fehler

? uj- @ | Original: StackOverFlow
---

Ich habe eine Reihe von Problemen, seit ich versucht, ein Android- Projekt importieren musste .

Die Lage meiner SDK wurde nicht in Einstellungen festlegen (auch wenn es vor hatte und ADT arbeitete völlig in Ordnung ) . Wenn ich versuche, den Pfad zum SDK Ordner festgelegt, heißt es

Das Android SDK erfordert Android Developer Toolkit Version 23.0.0 oder höher. Die aktuelle Version ist 22.6.2.v201403212031-1085508 . Bitte aktualisieren Sie ADT auf die neueste Version .   Also versuche ich, von Eclipse durch folgenden zu aktualisieren, da auf einem anderen SO Beitrag vorgeschlagen (seit "Nach Updates suchen " sagt mir, dass es keine Updates zur Verfügung :

Hilfe -> Installieren neuer Software -> p2repo - https://dl-ssl.google.com/android/eclipse/ - > Überprüfen Entwickler-Tools -> Weiter          Und das ist, wo ich die folgende Fehlermeldung :

Cannot complete the install because of a conflicting dependency.
Software being installed: Android Native Development Tools 23.0.2.1259578 (com.android.ide.eclipse.ndk.feature.feature.group 23.0.2.1259578)
Software currently installed: Android Developer Tools 22.6.2.v201403212031-1085508 (com.android.ide.eclipse.adt.package.product 22.6.2.v201403212031-1085508)
Only one of the following can be installed at once: 
ADT CDT Integration 23.0.2.1259578 (com.android.ide.eclipse.ndk 23.0.2.1259578)
ADT CDT Integration 22.6.2.v201403212031-1085508 (com.android.ide.eclipse.ndk 22.6.2.v201403212031-1085508)
Cannot satisfy dependency:
From: ADT Package 22.6.2.v201403212031-1085508 (com.android.ide.eclipse.adt.package.feature.group 22.6.2.v201403212031-1085508)
To: com.android.ide.eclipse.ndk.feature.group 22.6.2

Cannot satisfy dependency:
From: Android Developer Tools 22.6.2.v201403212031-1085508 (com.android.ide.eclipse.adt.package.product 22.6.2.v201403212031-1085508)
To: com.android.ide.eclipse.adt.package.feature.group [22.6.2.v201403212031-1085508]

Cannot satisfy dependency: 
From: Android Native Development Tools 23.0.2.1259578 (com.android.ide.eclipse.ndk.feature.feature.group 23.0.2.1259578)
To: com.android.ide.eclipse.ndk [23.0.2.1259578]

Cannot satisfy dependency:
From: Android Native Development Tools 22.6.2.v201403212031-1085508  (com.android.ide.eclipse.ndk.feature.group 22.6.2.v201403212031-1085508)
To: com.android.ide.eclipse.ndk [22.6.2.v201403212031-1085508]

Wie kann ich erfolgreich um diese Fehlermeldungen erhalten und zu aktualisieren Sonnenfinsternis ?

---

Top 5 Antwort

1The_ehT @

Einfach deinstallieren aktuellen ADT Version ist 22.6.2.v201403212031-1085508, indem Sie auf Hilfe > Einbaudetails > installierten Software und wählen Sie dann ADT ( alte Version ) > klicken Sie auf Deinstallieren . Jetzt installieren neuesten ADT . Auf diese Weise konnte ich ADT auf die aktuelle Version zu aktualisieren, hoffe, es hilft . Hinweis: Dies wird nicht auf adt - Bündel zu arbeiten.

2Lightshadow @

Heute habe ich den gleichen Fehler, wie Sie :

Das Android SDK erfordert Android Developer Toolkit Version 23.0.0 oder höher. Die aktuelle Version ist 22.6.2.v201403212031-1085508 . Bitte aktualisieren Sie ADT auf die neueste Version .

YOUR MESSAGE:

Das Android SDK erfordert Android Developer Toolkit Version 23.0.0 oder höher. Die aktuelle Version ist 22.6.2.v201403212031-1085508 . Bitte aktualisieren Sie ADT auf die neueste Version .

Ich reparierte es in 5 Minuten :

1 Stellen Sie sicher, haben Sie immer noch die Zip-Datei ( mir ist es " adt - Bundle -windows- x86_64-20140321 " )

2 Kopieren Sie den Inhalt der Zip, wo Sie es haben wollen

3 Es ist, als 1,30 GB (glaube ich), so dass je nach Computer könnte es ein paar Minuten dauern

4 Sobald es kopiert, öffnen Sie es .

5 Gehen Sie in der Eclipse- Ordner, öffnen Sie die Eclipse- Anwendung (man kann sogar stecken Sie es in der Taskleiste, wenn Sie es eine Menge zu verwenden )

Ich hatte dieses Problem ein paar Mal, und das immer funktioniert für mich.

3Lightshadow @

Für Sanjay Manohar :

Grundsätzlich, wenn Sie Eclipse heruntergeladen, war es in einer ZIP-Datei . Sie benötigt, um die Dateien, um seine Inhalte zu verwenden extrahieren. Die Datei, die ich heruntergeladen wurde " adt - Bundle -windows- x86_64-20140321 " genannt, und ich habe es von " https://developer.android.com/training/basics/firstapp/index.html " .

Wenn Sie Eclipse sind, haben Sie wahrscheinlich die Zip-Datei in Ihrem Download, so dass keine Notwendigkeit, es wieder zu laden.

Wenn ich Sie wäre, würde ich eine Datei namens "Android " zu machen, und in ihm Platz die ZIP-Datei ( als künftige Backup verwenden, wenn Sie ähnliche Probleme haben )

Ich würde auch einen Ordner namens Arbeitsbereich für alle meine Projekte und ein Ordner mit dem Namen ADT, in dem ich den Inhalt der Zip-Datei zu extrahieren.

Dies würde die Ordner im "Android " sein :

-ADT (-> Enthält die extrahierten Dateien aus der Zip-Datei " adt - Bundle -windows- x86_64-20140321 " )

-workspace (-> enthält meine Projekte )

-adt - Bundle -windows- x86_64-20140321 (-> die ZIP-Datei )

Sorry für die Schaffung einer neuen Antwort, ich habe nicht den Ruf ...

4priya @

Deinstallieren Sie alle widerstreitenden Komponenten . In meinem Fall, Open -GL, DDMS wurden ADT etc mit dem Update in Konflikt . Also ich deinstalliert alle von diesen, mit ..

Hilfe-> Über Eclipse- SDK- > Installation Details- > wählen Sie die Komponente, um uninstall- > uninstall

Dann aktualisieren Sie Ihre ADT .

Help-> Install New Software- > Wählen Sie die Update-Site Adt ( https://dl-ssl.google.com/android/eclipse/ wenn nicht präsentieren hinzufügen ) verfügbar in s / w- Seiten. Und aktualisieren Sie die ADT .

5Ankit Sachan @

Wählen Sie einfach ADT von Entwickler-Tools im Dropdown-