Mit 1,7 erfordert Kompilieren mit Android 4.4 ( KitKat ); Zeit als API 14

? user3810543 @ | Original: StackOverFlow
---

So vor kurzem wechselte ich das Ziel meiner android Projekt 4.0 . Jetzt habe ich praktisch Fehler in jeder Zeile und dem Fehler " Mit 1,7 erfordert Kompilieren mit Android 4.4 ( KitKat ), zur Zeit als API- 14" auf der Konsole. Also meine Frage ist, wie kann ich das ändern, mit api 14 arbeiten und kompilieren? danke shon.

---

Top 5 Antwort

1Eran @

In Eclipse : Rechtsklicken Sie auf Ihr Projekt -> Eigenschaften -> von der Seite Bar, holen "Java Compiler" und ändern Sie dann Compiler Compliance-Niveau auf 1,6

2Justin @

Ich bin nicht einverstanden mit Eran, diesen Fehler zu verursachen, indem Sie Project build target 4,0 (API 14) . Wenn Änderungen an Java 1.6, werden Sie nicht verwenden können, Java 1.7 sode Stil, zum Beispiel: ArrayList myArrayList = new ArrayList<>(); .  Um dies zu beheben, stellen Sie Ihre Zielgruppe auf 4,4 (API 19) oder höher.