Android Studio : Fehler zu finden : " com.android.support:support-v4:19.1.0 '

? MrHill @ | Original: StackOverFlow
---

Ich möchte eine App in Android Studio mit der Support-Bibliothek aufbauen, aber ich bekomme die folgende Fehlermeldung beim Hinzufügen der Abhängigkeiten für die Support-Bibliothek :

Error:Failed to find: com.android.support:support-v4:19.1.0

Hier ist meine build.gradle Datei

apply plugin: 'com.android.application'

android {
    compileSdkVersion 19
    buildToolsVersion '20'

    defaultConfig {
        applicationId "sample.myapplication"
        minSdkVersion 15
        targetSdkVersion 19
        versionCode 1
        versionName "1.0"
    }
    buildTypes {

        release {
            runProguard false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }
}

dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    compile 'com.android.support:support-v4:19.1.0'

}

Ich habe den Support-Bibliothek über das SDK -Manager heruntergeladen .

---

Top 5 Antwort

1MrHill @

Ok, das Problem gefunden . Die Android -Unterstützung Repository fehlte. Nach der Installation und dem Neustart Android Studio es funktionierte.

2Patrick @

Wenn Sie Android Studio, dann als Ergänzung zum manuellen Ändern der build.gradle -Datei, können Sie auch die Abhängigkeit Lookup über die Bibliotheksabhängigkeiten unter dem Menüpunkt Projekt Struktur .

Android Studio : Fehler zu finden : " com.android.support:support-v4:19.1.0 '

Ein Doppelklick auf diese Abhängigkeit wird diese Zeile in build.gradle erzeugen :

dependencies {
    compile 'com.android.support:support-v13:+'
}

Und auch, wenn Sie sich fragen, was diese Bibliothek zu, es ist an den Entwickler -Seiten bei developer.android.com beschrieben ; http://developer.android.com/tools/support-library/index.html .

3natur3 @

Im Anschluss an die Anweisung hier hat mir geholfen. Aus irgendeinem Grund, wenn ich auf die neueste Version von Android- Studio die erste Download der Extras Sektion android Support-Bibliothek gescheitert neu installieren. Ich erneut versucht es einfach . Folgte den genannten Schritte und überprüft sie auf die build.gradle Datei hinzugefügt und hat eine Umbauprojekt und gut zu gehen.

http://developer.android.com/tools/support-library/setup.html