Das Android SDK erfordert Android Developer Toolkit Version 23.0.0 oder höher

? Kalpesh @ | Original: StackOverFlow
---

Ich bekomme die folgende Fehlermeldung, wenn ich meinen Eklipse .

Das Android SDK erfordert Android Developer Toolkit Version 23.0.0 oder höher

Und wenn ich versuche, von Hilfe zu aktualisieren > Neue Software installieren ... mit Hilfe des Eclipse- Update- Link https://dl-ssl.google.com/eclipse/plugin/4.2

Es gibt mir folgende Fehlermeldung:

Cannot complete the install because of a conflicting dependency.
Software being installed: Android Development Tools 23.0.1.1256982 (com.android.ide.eclipse.adt.feature.feature.group 23.0.1.1256982)
Software currently installed: Android Development Tools 22.6.3.v201404151837-1123206 (com.android.ide.eclipse.adt.feature.group 22.6.3.v201404151837-1123206)
Only one of the following can be installed at once: 
ADT XML Overlay 23.0.1.1256982 (overlay.com.android.ide.eclipse.adt.overlay 23.0.1.1256982)
ADT XML Overlay 22.6.3.v201404151837-1123206 (overlay.com.android.ide.eclipse.adt.overlay 22.6.3.v201404151837-1123206)
Cannot satisfy dependency:
From: Android Development Tools 23.0.1.1256982 (com.android.ide.eclipse.adt.feature.feature.group 23.0.1.1256982)
To: overlay.com.android.ide.eclipse.adt.overlay [23.0.1.1256982]
Cannot satisfy dependency:
From: Android Development Tools 22.6.3.v201404151837-1123206 (com.android.ide.eclipse.adt.feature.group 22.6.3.v201404151837-1123206)
To: overlay.com.android.ide.eclipse.adt.overlay [22.6.3.v201404151837-1123206]

Was soll ich jetzt machen?

---

Top 5 Antwort

1Dhawal Sodha Parmar @

keine Notwendigkeit, etwas zu tun ,

laden Sie einfach neue Eclipse installieren ADT 23.0.0 aus folgenden Link

https://dl-ssl.google.com/android/eclipse/

Ihr Problem lösen ...

seine passiert, weil Sie SDK 23.0.1 und 23.0.1 Update ADT nicht verfügbar ....

yesterday i have same issue, i have solved that.. 2user285oo6 @

Wie Sie das Upgrade auf SDK 23.0 zu aktualisieren, ohne das ADT durchgeführt wird diese Art Fehler zeigen, wie Sie im Screenshot erwähnt haben .

Einfach Aktualisierung des SDK auf 23,0 nützt nichts, solange nicht auch die damit verbundene Entwicklungswerkzeug in ADT aktualisieren.

Folgen Sie den Schritten

First delete the SDK 23.0 and update the ADT to 23.0 For doing the update you need to click on Install new software from help and choose the ADT/ https://dl-ssl.google.com/android/eclipse/ under the link upon which you get the new Development tools to update click all >next to continue . Upon successful completion you can now update the SDK to 23.0.

Hinweis: - Viele, die das SDK zu aktualisieren, versucht haben, vor einem Problem kann nicht wegen des Konflikts dependancy die Installation  Das Android SDK erfordert Android Developer Toolkit Version 23.0.0 oder höher

So ist es besser, nur um die 22.6v des ADT -Stick. Das Update auf 23.0 wird Jill ist und es einige Zeit, um die Fehler zu beheben nehmen

3Kikiwa @

Wenn Sie einen Konflikt mit der Vorgängerversion :

Select Help > Install New Software Click on already installed Select all Android software on version 22.* Click on Uninstall Work with: https://dl-ssl.google.com/android/eclipse/ Select Developer Tools and Next Next, Accept the license agreement and Finish.

EDIT: Dieser Trick ist wahrscheinlich nicht notwendig mehr !

Versuchen Sie, Ihre SDK-Tools zu 23.0.2+ aktualisieren und bauen & amp; Plattform Tools rev 20 vor .

4Kalpesh @

Die beste Lösung ist, um eine neue ADT von http://developer.android.com/sdk/index.html downloaden

5Joff @

Kalpesh NICHT löschen SDK 23.0 es wird Ihre "Werkzeuge" Ordner zu entfernen und Sie werden nicht in der Lage, SDK -Manager danach laufen. Ich weiß, weil ich gerade getan. Bad Vorschlag!

Die Lösung von Kikiwa für mich gearbeitet.