ADT -Plugin kann nicht aktualisiert werden in Eclipse auf Version 23.0.0 oder höher

? adamhala007 @ | Original: StackOverFlow
---

Ich bin Anfänger in Android -Programmierung. Mein Problem ist, dass ich nicht ADT aktualisieren. Das Problem begann, als nach einer langen Zeit, die ich in der Android SDK -Manager die Android SDK -Tools aktualisiert. Dann habe ich versucht, ein Projekt in den Arbeitsbereich importieren. Aber ich konnte nicht importiert werden, dass, weil jedes Mal, wenn ich klickte auf die Schaltfläche Fertig, geschah nichts. Dann schloss ich Eclipse und öffnete sie wieder, und zeigte mir die folgende Fehlermeldung:

ADT -Plugin kann nicht aktualisiert werden in Eclipse auf Version 23.0.0 oder höher

Ich klickte auf den Check for Updates, aber es half nichts. Im Internet habe ich eine URL ( https://dl-ssl.google.com/android/eclipse/ ) gefunden, so dass ich geklickt Hilfe -> Neue Software installieren ...-- > Add -> und klebte diese URL . Als ich angeklickt Anschließend zeigte sie mir die Liste der Elemente, die ich installieren wollte und auch eine Fehlermeldung:

Cannot complete the install because of a conflicting dependency.
 Software being installed: Tracer for OpenGL ES 23.0.0.1245622 (com.android.ide.eclipse.gldebugger.feature.feature.group 23.0.0.1245622)
 Software currently installed: Tracer for OpenGL ES 21.0.0.v201210310015-519525 (com.android.ide.eclipse.gldebugger.feature.group 21.0.0.v201210310015-519525)
Only one of the following can be installed at once: 
Tracer for OpenGL ES 23.0.0.1245622 (com.android.ide.eclipse.gldebugger 23.0.0.1245622)
Tracer for OpenGL ES 21.0.0.v201210310015-519525 (com.android.ide.eclipse.gldebugger 21.0.0.v201210310015-519525)
Cannot satisfy dependency:
From: Tracer for OpenGL ES 23.0.0.1245622 (com.android.ide.eclipse.gldebugger.feature.feature.group 23.0.0.1245622)
To: com.android.ide.eclipse.gldebugger [23.0.0.1245622]
Cannot satisfy dependency:
From: Tracer for OpenGL ES 21.0.0.v201210310015-519525 (com.android.ide.eclipse.gldebugger.feature.group 21.0.0.v201210310015-519525)
To: com.android.ide.eclipse.gldebugger [21.0.0.v201210310015-519525]

Ich habe auch irgendwo gelesen, dass ich versuchen, den Ordner Plugins mit den aktualisierten Plugins ersetzen Ordner so habe ich versucht, im Ordner Eclipse " pluginsx " umbenennen Ordner "Plugins" und klebte den neuen habe ich von der Website http heruntergeladen //developer.android.com/sdk/installing/installing-adt.html . Danach konnte ich nicht das Eclipse zu öffnen.

Diese Seite ( http://stackoverflow.com/questions/24437564/update-eclipse-with-android-development-tools-23 ) ist auch über das gleiche Problem wie ich, und es gibt eine Antwort, die als Lösung akzeptiert wird, nicht in Frage. Also versuchte ich auch http://dl.google.com/android/android-sdk_r22.6.2-windows.zip auf Ordner, die in der folgenden Kommentar erwähnt wurden, downloaden und kopieren Sie diese 3 Dinge, aber ich habe immer noch das gleiche Problem, nichts geändert.

So jetzt habe ich keine Idee, wie man dieses Problem beheben . Kann jemand mir helfen, bitte?

Vielen Dank im Voraus.

---

Top 5 Antwort

1serifsadi @

Hilfe -> Neue Software installieren -> Was ist bereits installiert ?

Dann wählen Sie " Android DDMS, Andoid Devlopment Extras Android Hierarcy Viewer Android nativen Entwicklungstools, Android Traceview, Tracer für OpenGL ES " und klicken Sie auf Deinstallieren .

Nach all diesem Schritt versuchen einen Link hinzufügen ( https://dl-ssl.google.com/android/eclipse/ ) und Name ist ADT Plugin. Dieser Link wird die neueste ADT Plugin zu bekommen. Auf diese Weise setzen Sie die ADT .

2Stuart Siegler @

Keine dieser "update" allein Antworten für mich gearbeitet.

Die Lösung, die ich verwendet, ist es, die ADT (von Deinstallieren Android ADT) deinstallieren

Help > About Eclipse > Installation Details

Wählen Sie alle Android -Module ( mit Präfix com.android.ide ...)

und löschen Sie sie ( Uninstall ...) und wieder fügen Sie die Bibliotheken aus der

help > Install new software

Wie oben aufgeführt ....

3androider @

Die einzige Lösung, die für mich gearbeitet wurde, um die aktuelle Eclipse- ADT -Bundle aus dem Android http://developer.android.com/sdk/index.html downloaden

Nach dem Download ist, kopiert ich meine aktuelle SDK in einen Ordner wie ... / Entwicklung / sdk . Dann löschte ich das SDK, die mit diesem neuen Bundle kam .

Ich habe ADT Bundle in ... / Entwicklung / adt - Bündel -.... Nach dem Start ist, Jave Sie die neue Lage in sdk Window > Preferences > Android zu informieren, damit im SDK Location Ihnen die neue sdk Weg zu bringen . In meinem Fall : ... / Entwicklung / sdk .

Natürlich können Sie das SDK -Ordner innerhalb des neuen ADT Bundle -Ordner abgelegt, aber ich auf diese Weise, weil ich Android Studio als auch, so dass ich darauf die beiden IDEs zu derselben SDK.

Nach Beendigung dieser und werden sicherstellen, dass alles funktioniert Ich löschte die alte ADT Bundle -Ordner.

4ZakiMak @

Installieren von ADT ist ein großes Problem, speziell bei der Aktualisierung . Auch manchmal ist es einfach ein Schmerz zu ADT durch die direkte Verbindung zu installieren. Oft Eclipse Stall während der Anzeige von "Berechnung Anforderungen und Abhängigkeiten " .

Ich fand es einfacher, zu Zeiten, zunächst alle sieben Komponenten zu deinstallieren :

-Android DDMS -Andoid Devlopment Werkzeuge -Android Hierarcy Anzeige -Android Mutterentwicklungstools -Android Traceview -Tracer Für OpenGL ES -Google App Engine -Tools für Android (falls installiert)

Dann laden Sie die neueste ZIP / Archiv von http://developer.android.com/sdk/installing/installing-adt.html

Installieren Sie das Archiv vom Help-> Install New Software-> Add-> Archiv  Wählen Sie die heruntergeladene ZIP, einen Namen für sie und folgen Sie den Standard-Installationsprozess .