Android Studio sagt Gradle 1.10 verwenden - aber neue Version 1.12 ?

? KickingLettuce @ | Original: StackOverFlow
---

The error:

The project is using an unsupported version of Gradle.  Please use version 1.10.


My `gradle.build` file says this:

dependencies {
      classpath 'com.android.tools.build:gradle:0.12.+'
}

Soweit ich weiß, ist der obige Zeile richtig. Meine Datei gradle-wrapper, sagt :

distributionUrl=http://services.gradle.org/distributions/gradle-1.12-all.zip

Dies geschah, als ich zum Download der neuesten Android Studio beta ( V. 8 ) und versuchte, eine App, die hatte, was ich davon ausgehen, ist eine alte Version von Gradle importieren.

Auch, wenn ich auf " Fix Gradle Wrapper and re-import project ", passiert nichts.

---

Top 5 Antwort

1The Metal Beard @

Es gibt einen Unterschied zwischen Gradle Version und Gradle Android Plugin -Version (0.12 . +) . Sieht aus wie Sie benötigen Gradle Version 1.10, nicht später denken Versionen werden noch durch die Gradle Android Plugin supperted . Wie auch immer, ich denke, darauf achten, dass Sie Gradle 1.10 Version verfügen, dieses Problem zu beheben .

2The End @

Wenn Sie die gradle - Wrapper auf eine niedrigere Version wechseln wollen, müssen Sie distributionUrl ändern

distributionUrl=http://services.gradle.org/distributions/gradle-1.10-all.zip

und führen Sie dann erneut den Wrapper Aufgabe. Ist dies nicht genug, nur die Ordner .gradle und gradle und die Dateien gradlew und gradlew.bat löschen. Die Wiederholung Wrapper und er lädt gralde 1.10

Seit gradle hatte einige große api Änderungen von Version 1.10 und 1.12 können Sie jedes Projekt mit einer höheren Version nicht bauen dann die Plugins sind mit zu bauen. Also, wenn das Android- Plugin ist mit gradle 1,10 bauen Sie die gleiche Version verwenden