UnsupportedMethodException Android Studio 0.8.9

? user3184899 @ | Original: StackOverFlow
---

Ich habe Android Studio 0.8.9 . Bisher konnten Sie mit gradle Dateien erfolgreich zu synchronisieren, Aber heute, wenn ich sie öffnete, Es gibt mir diese Fehlermeldung:

UnsupportedMethodException
         Failed to set up Android modules in project 'Project': Unsupported method: SourceProvider.getJniDirectories().
         The version of Gradle you connect to does not support that method.
         To resolve the problem you can change/upgrade the target version of Gradle you connect to.
         Alternatively, you can ignore this exception and read other information from the model.

Können Sie mir helfen dieses Problem lösen? Danke Shon.

---

Top 5 Antwort

1Danuofr @

Um dieses Problem zu beheben Ich herabgestuft das android - Plugin in Ihren Projekten obersten Ebene build.gradle Datei     Klassenpfad ' com.android.tools.build:gradle:0.14.+ ' bis zur     Klassenpfad ' com.android.tools.build:gradle:0.13.+ '

Im Augenblick ist die Buildverfahrenin meinen Projekten build.grade aussieht

buildscript {
  repositories {
    mavenCentral()
  }
  dependencies {
    // NOTE: Do not place your application dependencies here; they belong
    // in the individual module build.gradle files
    classpath 'com.android.tools.build:gradle:0.13.+'
  }
}

Ich denke, es kann ein Fehler bei der Ausführung 0,14 sein, schickte ich meine Fehlerbericht .

2Jeff Brateman @

Wie vom angegeben http://stackoverflow.com/questions/26680972/unsupportedmethodexception-android-studio-0-8-9#comment42031754_26692486, Upgrade auf Android Studio 0.9.0 behebt dieses Problem .