Update Eclipse Android Development Tools v . 23

? greywolf82 @ | Original: StackOverFlow
---

Ich aktualisiert mit den neuen Eclipse- SDK-Tools ( rev 23), aber jetzt, wenn Eklipse beginnt die Fehlermeldung I:

Das Android SDK erfordert Android Developer Toolkit Version 23.0.0 oder höher. Die aktuelle Version ist 22.6.3.v201404151837-1123206 . Bitte aktualisieren Sie ADT auf die neueste Version .

Keine Updates wurden mit "Nach Updates suchen " gefunden. Wenn ich versuche, " Installieren neuer Software ", kann ich die Version 23 zu sehen, aber ich kann nicht aufgrund des folgenden Fehlers zu aktualisieren:

Cannot complete the install because of a conflicting dependency.
Software being installed: Android Development Tools 23.0.0.1245622 (com.android.ide.eclipse.adt.feature.feature.group 23.0.0.1245622)
Software currently installed: Android Developer Tools 22.2.1.v201309180102-833290 (com.android.ide.eclipse.adt.package.product 22.2.1.v201309180102-833290)
Only one of the following can be installed at once: 
    ADT Package 22.6.3.v201404151837-1123206 (com.android.ide.eclipse.adt.package 22.6.3.v201404151837-1123206)
    ADT Package 23.0.0.1245622 (com.android.ide.eclipse.adt.package 23.0.0.1245622)
Cannot satisfy dependency:
    From: Android Development Tools 23.0.0.1245622 (com.android.ide.eclipse.adt.feature.feature.group 23.0.0.1245622)
    To: com.android.ide.eclipse.adt.package [23.0.0.1245622]
Cannot satisfy dependency:
    From: Android Development Tools 22.6.3.v201404151837-1123206 (com.android.ide.eclipse.adt.feature.group 22.6.3.v201404151837-1123206)
    To: com.android.ide.eclipse.adt.package [22.6.3.v201404151837-1123206]
Cannot satisfy dependency:
    From: ADT Package 22.2.1.v201309180102-833290 (com.android.ide.eclipse.adt.package.feature.group 22.2.1.v201309180102-833290)
    To: com.android.ide.eclipse.adt.feature.group 22.2.0
Cannot satisfy dependency:
    From: Android Developer Tools 22.2.1.v201309180102-833290 (com.android.ide.eclipse.adt.package.product 22.2.1.v201309180102-833290)
    To: com.android.ide.eclipse.adt.package.feature.group [22.2.1.v201309180102-833290]

Nach dem Download des letzten ADT auf der Website, so scheint es, gibt es ein weiteres Problem. Mit SDK Werkzeuge rev. 23 proguard nicht installiert ist, wird der Ordner SDK dir/tools/proguard fehlt und andere Werkzeuge fehlen. Diese Version enthält einige Fehler .

---

Top 5 Antwort

1Daniel Díaz @

UPDATE : Google hat ADT v23.0.2 veröffentlicht . Dies löste viele Probleme der früheren ADT Version 23 .

Step-by-step:

Help -> Install New Software... For "Work with", select the Android source https://dl-ssl.google.com/android/eclipse Update Eclipse Android Development Tools v . 23 Tick ADT v23.0 for installation, then click "Next" Eclipse will show "Install Remediation Page" since there is conflict with previous version. (If it does not, see below.) Select "Update my installation to be compatible with items being installed" to uninstall the old version and install the new one. After that, proceed with the usual steps Update Eclipse Android Development Tools v . 23

Hinweis: Wenn ich die neue Version von ADT installiert, ich habe nicht die neue Version von Paket " Android Mutterentwicklungstools" . Stattdessen installierte ich den Rest der Pakete zuerst, und dann installiert " Android Mutterentwicklungstools" . Aus einem Grund, wenn ich versuche, alle neuen Paketen, darunter " Android Mutter Development Tools" zu installieren, schlägt die Installation fehl .

UPDATE : Wenn es keine " Remediation Seite ", http://stackoverflow.com/a/9097282/755804 Aber es besteht die Gefahr der Deinstallation von Eclipse selbst.

2bluewhile @

Für mich ist es dazu beigetragen, Android 4,4 W, die auch API- 20 und könnte eine Ursache für den Konflikt zu löschen. So installieren Sie nur 4,4 W oder Android Android L, bis sie es zu beheben.

Und ( auch dies kann nur für mich ) es funktioniert nur in Android Studio in Eclipse ...

3Rajat Sharma @

Ich habe folgendes auf ein Problem zu lösen getan .

Zum http://developer.android.com/sdk/installing/installing-adt.html und laden Sie die neueste ADT ZIP-Datei ( am Ende der Seite) .

Gehen Sie in Eclipse -> Hilfe - > Über Eklipse -> Installation Details

Löschen Android DDM, Android Development Tools, Hierarchie Viewer Mutterentwicklungstools, Traceview, etc., 22.x Version .

Hilfe -> Neue Software installieren -> Hinzufügen -> Archiv -> Wählen Sie die heruntergeladene ZIP-Datei in Schritt 1 .

Wählen Sie alle die neueste Version von allen 23, die ich in Schritt 3 gelöscht und die Lizenzvereinbarung akzeptieren .

Starten Sie Eclipse und es mein Problem behebt .

4stevyhacker @

Auf ADT gebündelt Eklipse musste ich zuerst die ADT deinstallieren und dann neu installieren müssen . Um die ADT -Plugin von Eclipse- entfernen gehen Sie zu Hilfe > Über Eklipse > Einbaudetails . Wählen ADT -Plug-in, klicken Sie auf Deinstallieren . Nach der Deinstallation installieren ADT von Hilfe> Installieren neuer Software.

5Biljana @

DO NOT DO THIS

Achtung: Bitte beachten Sie die Kommentare unterhalb dieser Antwort. Diese Schritte haben negative Auswirkungen für viele Menschen hatte .

Click Help / Install new software... Click on What is "already installed" (as in picture below) In the new window you can uninstall the old ADT (uninstall Android Development Tools, Android DDMS, Android Hierarchy Viewer, Android TraceView, Android Native Development Tools and Tracer for OpenGL ES) Restart Eclipse Then again click on Help / Install New Software Choose ADT... Install

Ich hoffe, es hilft!

Update Eclipse Android Development Tools v . 23