Google adt / gwt Unterstützung für Eclipse 4.4 ( Luna )

? MTilsted @ | Original: StackOverFlow
---

Haben jedermann die Release-Version von Eclipse 4.4 mit adt ( Android Entwicklung ) und / oder das Google Web Toolkit (GWT) zu arbeiten bekommen .

Es scheint, wie die gwt / adt Plugins nicht funktioniert mit Eclipse 4.4, so gibt es einen geheimen Ort, um neue Versionen downloaden, oder sollte ich halten mit 4,3 - (

edit: Der Grund, warum ich dachte, adt nicht funktionierte, war, dass die Dokumentation ( http://developer.android.com/sdk/installing/installing-adt.html ) sagt, dass das Plugin namens " ADT Plugin", das es nicht ist.

---

Top 5 Antwort

1user3396807 @

For adt,

Hilfe -> Installieren neuer Software ->    https://dl-ssl.google.com/android/eclipse/ -> nicht alles auswählen

( es funktioniert auch so für mich), die ich ausgewählt alles außer Mutterentwicklungswerkzeuge( ich denke, Sie brauchen sie nicht, wenn Sie in Java debelop ) und es ist gut für mich arbeiten.

2raywang @

na ja ... die GWT -Plugin eigentlich nicht mit luna Release arbeiten, da es ein Bündel Abhängigkeit für eclipse core.runtime [ 3.8.0,3.10.0 ) hat, hier " ) " bedeutet, dass es NICHT beinhaltet 3.10.0 wihich in luna verwendet jedoch kann es schon loswerden, indem Sie die OSGi-Bundle -Datei und dann wird es funktioniert mit luna, zumindest für mich für den Moment.

1 Laden Sie die letzte Aktualisierungssite -Datei von Google- Eclipse-Plugin Website 2 entpacken 3, dann müssen Sie 2 Dateien zunächst ändern

OSGi META INF / Dateiaufstellung in einem Glas mit dem Namen * gdt * e42 (sorry, vergessen, den vollständigen Namen, können Sie es finden, wenn Sie versuchen, das Plugin zu installieren, wird luna beklagen, dass einige dep Paket verpasst ), die sich enthalten Plugins in dir, nur core.runtime Version 3.10.0 ) zu ändern 3.10.0 ]

ein anderer sollte über contents.jar (vielleicht Artefakte. jar ), gleich sein

jetzt können Sie, wenn Sie bereits die Eclipse RCP installiert das Plugin zu installieren

jedoch installiert wird fehlgeschlagen, da der MD5- Hash geändert wird,

endlich, kopieren Sie die erwarteten md5 von Dialogfehlermeldung, die alte MD5- Wert im artifacts.jar ersetzen (vielleicht contents.jar )

Jetzt installieren Sie das Plugin, sollte es jetzt funktionieren

UPDATED:

vielleicht sollten Sie das Bundle - Version von MANIFEST.MF bei com.google.gdt.eclipse.platform.e42 jar entfernen und ändern Sie die Version " 0.0.0 " aus content.xml bei content.jar

3MrTux @

Google hat soeben seinen offiziellen SDK for Eclipse Luna: https://developers.google.com/eclipse/docs/getting_started

4ojonugwa ochalifu @

Wenn Sie mit der Option Help----->Install New Software sind, können Sie diese Fehlermeldung auftreten wie ich habe versucht, das Android -Plugin installieren.

An error occurred during the org.eclipse.equinox.internal.p2.engine.phases.CheckTrust phase. session context was:(profile=epp.package.jee, phase=org.eclipse.equinox.internal.p2.engine.phases.CheckTrust, operand=, action=). Error reading signed content. error in opening zip file

Meine Lösung war, durch Help-->Eclipse Marketplace gehen und dann für "Android" Wählen Sie das Plugin aus dem Suchergebnis und installieren Sie es von dort zu suchen.