Android Studio nach dem Update auf 19.1.0 Werkzeuge bauen

? Ilya_Gazman @ | Original: StackOverFlow
---

Upgrade lässt Android Build-Tools Version 19.1.0 und das ist, worauf ich hinaus will :

Nicht unterstützte Methode : Dependencies.getJars ().             Die Version von Gradle Sie eine Verbindung zu nicht unterstützt diese Methode .             Um das Problem zu lösen, die Sie ändern können / aktualisieren Sie die ZielversionGradle Sie verbunden werden.             Alternativ können Sie diese Ausnahme zu ignorieren und lesen Sie weitere Informationen aus dem Modell .: Nicht unterstützte Methode :   Dependencies.getJars ().

Ich suchte alle meine Bibliotheken und Abhängigkeiten und alle auf 19.1.0 eingestellt

Was bin ich dabei?

---

Top 5 Antwort

1Berdon @

Version 0.11 des Android Gradle Plugin wurde gerade veröffentlicht ( 6/6/14 ) . Ändern Sie Ihr build.gradle Einstellungen auf " 0.10 . +" .

classpath 'com.android.tools.build:gradle:0.10.+'

Hinweis: Diese sollte als eine vorübergehende Lösung, bis Sie Android Studio und Ihr Android SDK (insbesondere Ihre Build-Tools ) zu aktualisieren.

2Prakash @

Aktualisiert Android Studio, die das Problem behoben ist.

3Yuki Yoshida @

Dieser Fehler tritt bei IntelliJ IDEA, auch. und ich versuche, eine Version von IntelliJ IDE

bauen Werkzeug 19.1.0 und gradle Plugin 0.11

Android Studio 0.8.1 : build success IntelliJ IDEA 13.1 : this error still occurs at IU-135.760 IntelliJ IDEA 13.1 EAP : this error still occurs at IU-135.1019 IntelliJ IDEA 14 EAP : build success at IU-138.777

Ich kann dieses Update in 14 EAP Release findet, aber es scheint bei 14 EAP befestigt werden.