Android Studio Gradle build Revision

? Gabriel Matusevich @ | Original: StackOverFlow
---

Ich habe ein Android -Projekt im Android Studio 0.5.9 und Gradle wirft diese Fehlermeldung:

Error:The SDK Build Tools revision (17.0.0) is too low. Minimum required is 19.0.0

Ich habe bereits installierten SDK Build- Werkzeuge Revision 19 aus dem SDK -Manager und ist mein build.gradle hier

buildscript {
    repositories {
        mavenCentral()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:0.10.+'
    }
}
apply plugin: 'android'

repositories {
    mavenCentral()
}

android {
    compileSdkVersion 17
    buildToolsVersion "19.0.0"

    defaultConfig {
        minSdkVersion 9
        targetSdkVersion 17
    }

    sourceSets {
        main {
            manifest.srcFile 'Manantiales/src/main/AndroidManifest.xml'
        }
    }
}

Wie kann ich feststellen gradle, um die Build- Werkzeuge 19 zu verwenden, wenn es bereits installiert ist ?

EDIT: Ich markiert eine andere Antwort als die beste Antwort, weil es die eine, die für die meisten Menschen arbeiteten

---

Top 5 Antwort

1Gabriel Matusevich @

Ich fand das Problem, build.gradle war auf dem falschen Ordner

2Azurai @

Ich habe gerade vor kurzem aktualisierte mein android Studio 0.6.0, und es gab mir das gleiche Problem. Aber mein build war 19.0.3, 19.1.0 statt . Ich habe die buildToolsVersion " 19.0.3 " auf -> " 19.1.0 ", die sie zwang die Gradle, um die Updates herunterzuladen. Ich neu gestartet meinem Android Studio, und der Fehler ging weg. Nicht sicher, wie genau zu erklären, aber ich denke, es zwingt sie, um den Patch aus dem Maven Website herunterladen, und tut sein Gerechtigkeit hinter Kulissen. Und so wie Gabriel Matusevich sagte, wird die build.gradle befindet ProjectFolder -> AppFolder -> build.gradle

Ausnahme: Ich haben zu diesem Thema geprüft abgeschlossen this out, aber ich habe bemerkt das Gradle wurde von der Website heruntergeladen haben, ich hinzugefügt oder gelöscht Code haben zu diesem Thema, oder lief noch die Anwendung. So sicher sein, daran erinnern, die buildToolsVersion Nummer, die Sie zuvor !

3Jorge Vieira @

Öffnen Android SDK -Manager und stellen Sie sicher, Build-Tools 19.1 heruntergeladen . Doppel -Check.

Dann finden Sie bauen / app.gradle und ändern buildToolsVersion Nummer '19 .1 ':

apply plugin: 'android'

android {
    compileSdkVersion 19
    buildToolsVersion '19.1'
    defaultConfig {
        minSdkVersion 10
        targetSdkVersion 19

    }
4Xexiz @

Ich hatte das gleiche Problem heute Morgen nach dem Update auf .6.0 . Du brauchst, um gradle Version in /projectName/build.gradle ändern

classpath 'com.android.tools.build:gradle:0.11.+'

Öffnen Sie die SDK -Manager und laden Sie die neue Version des Build-Tools 19.1 ändern Sie die folgende Zeile in /projectName/moduleName/build.gradle

android {
  compileSdkVersion 19
  buildToolsVersion "19.1" //This version needs to be updated to 19.1 after SDK update

  ...

}

Dann synchronisieren Sie Ihre gradle Dateien, und Sie sollten gut zu gehen !

5RoQ @

Hallo für mich nach dem Download der letzten Version des Android SDK -Tools, die Android-Version F4 ändern I ( Modul-Einstellungen )

https://www.dropbox.com/s/9ypuepxfwlcp4e5/Captura%20de%20pantalla%202014-06-10%2000.45.38.png