Android Studio nicht com.android.support:support-v4:19.1.0 finden

? Mazzy @ | Original: StackOverFlow
---

Ich habe ein Projekt in Android Studio importiert, aber ich habe den Fehler:

Konnte nicht gefunden werden com.android.support:support-v4:19.1.0 .

Wo könnte ich diese Datei zu finden ? Ich habe das Projekt importiert Verwendung Gradle .

Ich habe die Android Studio version 0.5.7 die letzte android sdk und java 1.7u55 .

---

Top 5 Antwort

1CurlyPaul @

Ich hatte das gleiche Problem mit dem Morgen. Ich fand die Jar-Datei, die ich brauchte auf /<MySdkFolder>/extras/android/support/ - in gibt es einige Unterverzeichnisse mit den verschiedenen Unterstützungsbibliothekenin ihnen, so dass der letzte Teil des Weges ist abhängig von welcher eine, die Sie verwenden möchten .

Ich habe gerade kopiert in das lib -Ordner des Projekts. Ich bin sicher, es gibt eine weitere technische Lösung, aber es funktionierte für mich .

2kudzmi @

Fügen Sie einfach diesen Code, um Sie Datei build.gradle

dependencies {
    compile 'com.android.support:support-v4:19.+'
}

und drücken Sie Extras -> Android -> Sync Projekt mit Gradle Dateien

Gradle notwendig Dateien selbst herunterladen

3ffddani @

Es ist nicht für mich funktionieren. Es arbeitet mit 19.0.1 Aber wenn (ich benutze gradle ) Ich tue dies in meiner build.gradle :

repositories {
    def androidHome = System.getenv("ANDROID_HOME")
    mavenCentral()
    maven {
        url "$androidHome/extras/android/m2repository/"
    }
}

Er findet das Artefakt .

4xXJJJasonMokXx @

Rechtsklick auf die Bibliothek und wählen Sie die Importbibliothekals Option aus dem Kontextmenü funktioniert für mich.

5nenick @

Nach der Theorie funktioniert bei mir :

Android Studio hat Probleme, den Import Support - v4 : . 19,1 + Bibliothek, wenn es durch eine transitive Abhängigkeit kommt .

Lösung Hinzufügen von Unterstützung - v4 als eigene Abhängigkeit und verstehen diese lib, wo es transitiv kommt . dann konnte ich nicht mehr zu sehen dieses Import Ausgabe