Diese Klasse sollte öffentlich sein ( android.support.v7.internal.widget.ActionBarView.HomeView )

? HeadShotNot @ | Original: StackOverFlow
---

Ich versuche, eine Applikation für Android die 3 Spinner verwendet erstellen. Ich erhalte diesen Fehler, und ich kann nicht herausfinden, wie man es beheben . Diese Klasse sollte öffentlich sein ( android.support.v7.internal.widget.ActionBarView.HomeView )

---

Top 5 Antwort

1Olgierd @

Ich fand eine Lösung, in der project.properties Datei, ersetzen Sie einfach die Zeile sagen

android.library.reference.1=../appcompat_v7_3 

with

android.library.reference.1=../appcompat_v7

Das löste das Problem zumindest für mich .

2noob guest @

Dies ist nicht eine echte Lösung, aber vielleicht helfen.

Neues Projekt mit höheren API-Ebene dann 8 .

Immer, wenn ich wählen Minimum Required SDK auf API-Ebene 9 statt 8 dieser Fehler nicht passieren.

Beobachtung: Meine letzte Antwort gelöscht wurde, vielleicht der Moderator glaube, es war kaum mehr als ein Link auf eine externe Seite, aus diesem Grund, ich habe nicht die Verbindung erneut ein .

3Paulo Diogo @

Wenn Sie mit Eclipse sind :

Project > Clean > OK

Or Try:

Preferences -> Android Lint Preferences

Suche nach Instantiatable und als Warning gesetzt.

http://developer.android.com/tools/debugging/improving-w-lint.html

Dieser arbeitete für mich .

4user3809445 @

Auf der " v7 - appcompat " Bibliothek :

Einstellungen -> Android Lint Einstellungen

Suche nach " Instantiatable " und Warnung gesetzt .

5pixparker @

Eclipse in den Setup-Probleme . Fenster - > Einstellungen -> Android ->   Lint Fehlerprüfung   - > Eingabe von " Instantiatable " Innerhalb der Schwerpunkte - > wählen Sie den Inhalt - > rechts unten Severity Wahl Warnung -> OK!