eclipse kann android.support.v4.widget.SwipeRefreshLayout nicht gefunden

? Katedral Pillon @ | Original: StackOverFlow
---

Auch, sobald Sie auf Hinzufügen Dienst Bibliothek auswählen und Version 19, Eclipse noch nicht finden können, android.support.v4.widget.SwipeRefreshLayout . Wer weiß, wie zu ankommen dieses zu wirken ? Ich bin mit

<uses-sdk
android:minSdkVersion="11"
android:targetSdkVersion="19" />

Ich bin auf einem Mac -Computer mit Mavericks Juno arbeitet .

Update : import Abschnitt

import java.util.Observer;

import android.content.Intent;
import android.os.Bundle;
import android.support.v4.app.DialogFragment;
import android.util.Log;
import android.view.View;
import android.widget.AdapterView;
import android.widget.AdapterView.OnItemClickListener;
import android.widget.ListView;
import android.widget.TextView;
import android.support.v4.widget.SwipeRefreshLayout;//red underline

Update

Übrigens, ich weiß nicht, ob das wichtig ist : das ist eine App Engine Vernetztes Android -Projekt, das ich bauen mit Google - Eclipse- Plugin -

Update 3:

Es ist wie im Android Support Library 19.1.0 suchen, nicht über das SDK -Manager zur Verfügung. Wie sonst könnte ich es erhalten ?

---

Top 5 Antwort

1tehnolog @

Ich hatte das gleiche Problem mit dem alten Projekt . Aber wenn ich neues Projekt erstellen, können Eklipse dieses Import finden.

2user936580 @

Es sieht so aus, als ob Sie nicht über die Android -support- v4.jar in Java -Erstellungspfad haben . Fügen Sie sie aus dem Android -support- v7 - appcompat .

3Katedral Pillon @

So stellt sich heraus die Bibliothek in der folgenden Position

/android-sdk-macosx/extras/android/m2repository/com/android/support/support-v4/19.1.0

Was den üblichen gegen

/android-sdk-macosx/extras/android/support

Auch musste ich Eclipse neu zu starten und gehen Sie auf Android SDK Manager immer und immer und immer wieder, bis die Version 19.1.0 auftaucht.

Ich hoffe, das jemand anders einige Mühe spart .

4Lee HyunSoo @

Das SDK -Manager Update Android Dienst Bibliothek zu 19.1.0 . Aber wenn man Android Tools verwenden > Add Support Library, Eclipse -Update Android Support Library auf 19,0 . Ich denke, dass dies ein Fehler ist . Kopieren Android Support Library 19.1.0 auf libs Ordner manuell .

5birdy @

Es ist ein Problem mit der Aktualisierung von Support-Bibliothek von Eclipse : https://code.google.com/p/android/issues/detail?id=67991

Einfach aktualisieren Sie es, indem Sie Android SDK -Manager manuell und neue v4 lib, um Ihr Projekt .