Fix Gradle Kompatibilitätsproblem beim Importieren Android Beispielprojekt

? Sebastien @ | Original: StackOverFlow
---

Android Studio ( 0.5.3 ) macht mich verrückt .

Ich hatte noch nie irgendwelche ernsthaften Probleme mit Eclipse und ADT . Android Studio ist eine andere Geschichte : Ich habe nicht in der Lage, ein einzelnes Projekt, um richtig mit ihm aufbauen zu bekommen.

Also, ich versuche, ein Android- Beispielprojekt (was ich vermute, hat richtig Gradle Einstellungen und sollten zum weiteren ) zu importieren:

C:pathToMyAndroidSDKsdksamplesandroid-19contentStorageProvider

Der erste Fehler, den ich bekommen ist folgende:

Failed to refresh Gradle project 'StorageProvider'
The project is using an unsupported version of Gradle. Please use version 1.10.
Please point to a supported Gradle version in the project's Gradle settings or in the project's Gradle wrapper (if applicable.)
Fix Gradle wrapper and re-import project Gradle settings

OK, also ich herunterladen Gradle 1.10, und ändern Sie die Projekt Gradle Einstellungen, so dass es verwendet diese lokale Gradle Verteilung statt die Standard gradle Wrapper (die im Beispielprojekt enthalten sein scheint ) .

Bekomme ich eine andere Fehler diesmal :

Failed to refresh Gradle project 'StorageProvider'
The project is using an unsupported version of the Android Gradle plug-in (0.8.3).
Version 0.9.0 introduced incompatible changes in the build language.
Please read the migration guide to learn how to update your project.

Ich weiß Gradle nicht genug wissen, um die Konfiguration zu mir wandern, und ich weiß nicht wirklich wollen.

Wie kann ich einfach die gradle Wrapper ohne gettting gerufen, um Gradle 1,10 ( die nicht mit dem Projekt ist kompatibel) verwenden ? Jede andere Lösung ist auch willkommen.

Anmerkung: Ich habe mit anderen Beispielprojekte in der android -19 Ordner versucht nur, die gleichen Fehler.

EDIT:

Ich habe mehr Glück versuchen, unter Linux mit der Kommandozeile ( gradlew build ) aufbauen musste .

Der Aufbau gelungen, unabhängig davon, was ich in build.gradle gesetzt :

classpath 'com.android.tools.build:gradle:0.9.+'

or

classpath 'com.android.tools.build:gradle:0.8.+' #(the original configuration of the sample project)

So scheint mein Problem durch Fehler in Android Studio verursacht werden.

---

Top 5 Antwort

1Gabriele Mariotti @

Ohne zu wissen, gradle, ist es ziemlich schwierig, dieses Problem zu beheben .

Gleichzeitig Android Studio ist eine Alpha-Version, so kann es schnell zu ändern, und jede Version können inkompatible Änderungen einführen

Hier die erste doc, über ein Projekt mit Android Studio zu lesen :  https://developer.android.com/sdk/installing/studio-build.html

Sie sind AS 0.5.3 mit, so dass Sie gradle zu verwenden 1.10 / 1.11 und die gradle Plugin 0.9.x

Es bedeutet, dass in Ihrem build.gradle Skript, die Sie verwenden müssen :

buildscript {
    repositories {
        mavenCentral()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:0.9.+'
    }
}

Kann in der Datei sein, müssen 0.8.3 .

Auch Sie haben gradle 1.10 / 1.11 zu bedienen. Sie sollten einen Ordner * project_folder / gradle / Wrapper * wo es eine Datei gradle-wrapper.properties .

Hier haben Sie die distributionUrl Schlüssel zu ändern, um eine dieser Version zu verwenden :

distributionUrl = http: //services.gradle.org/distributions/gradle-1.10-all.zip

Android Studio - Gradle - Gradle Plugin etwas Beziehung :

http://stackoverflow.com/questions/22252956/android-studio-gradle-issue-upgrading-to-version-0-5-0-gradle-migrating-from-0/22256954#22256954

Können Sie Ihre gradle Skript kann andere Probleme nach diesen Veränderungen haben .