Wie kann ich ein neues Projekt zu erstellen, ohne appcompat_v7

? Ankit Kumar @ | Original: StackOverFlow
---

Ich bin nicht in der Lage zu bekommen, warum appcompat_v7 wird automatisch erstellt ... finden es sehr irritierend .. bitte jemand helfen loszuwerden dieses Problem. Ich habe versucht, neues Projekt zu erstellen und festgestellt, wie diese für jedes neu erstellte Projekt .

---

Top 5 Antwort

1taxo @

Beim Erstellen von neuen Android -Projekt entfernen Sie das Häkchen vor " erstellen Tätigkeit" . Auf diese Weise Eclipse nicht automatisch das Bibliotheksprojekt " appcompat_v7 " importieren. Dann können Sie manuell müssen Haupttätigkeit zu schaffen. Seien Sie vorsichtig, was Sie verwenden, importiert, wenn Sie Sachen wie Fragment oder ActionBar .

http://stackoverflow.com/questions/22261288/why-eclipse-automatically-adds-appcompat-v7-library-support-whenever-i-create-a ist sehr nützlich.

Hoffe, das hilft ! :)

2Ishara Amarasekera @

Wenn Sie Ihre Anwendung zu erstellen, geben API 14 : Android 4.0 oder eine obere Version als Mindest SDK-Version .

3svg @

der Grund, warum Eclipse- tut dies, weil es eine Menge von Fragmentierung in verschiedenen Anbietern und Versionen von Android und die gleiche spiegelt sich in der API ist zu .. !! So in Ordnung zu halten alles, was glatte Android schlägt das Hinzufügen externen Bibliotheken in das Projekt und Eclipse hält sich an die gleichen .

Sie können über 7 gilt auch den Trick tun es loswerden, wenn Sie gebaut haben, Ziel und kompilieren Niveau gleich, mit Mindest SDK.

beziehen sich  http://stackoverflow.com/questions/22261288/why-eclipse-automatically-adds-appcompat-v7-library-support-whenever-i-create-a