Fehler: Das Android SDK erfordert Android Developer Toolkit Version 22.6.1 oder höher

? TheLittleNaruto @ | Original: StackOverFlow
---

Ich habe adt Version 22.6.1 bereits vor 2 Tagen installiert . Es war in Ordnung . Plötzlich Beim Öffnen eclipse heute hält es zeigt mir folgende Fehlermeldung:

Das Android SDK erfordert Android Developer Toolkit Version 22.6.1 oder höher. Die aktuelle Version ist 22.2.1.v201309180102-833290 . Bitte aktualisieren Sie ADT auf die neueste Version .

Hier Screenshot meines Eclipse Android SDK Manager:  Fehler: Das Android SDK erfordert Android Developer Toolkit Version 22.6.1 oder höher

Ich habe versucht, mit folgenden Schritten zu meinem Problem zu beheben, wie in diesen diskutiert https://code.google.com/p/android/issues/detail?id=67325

Help | Install new software Select the ADT update site (there are two, one with http:// and one with https://. If one doesn't work, try the other. Select the developer tools section and press next. You should see a dialog that says This software is already installed, an update will be performed instead. Clicking OK will lead to 22.6.1 being installed.

Aber leider hat es nicht für mich arbeiten.

Hier ist ein Screenshot Ich füge die den Fehler Ich erhalte während der Aktualisierung der Werkzeuge zeigt .

Fehler: Das Android SDK erfordert Android Developer Toolkit Version 22.6.1 oder höher

Wie werde ich ihn los ?

---

Top 5 Antwort

1X-ELECTRON @

Löschen Sie einfach die vorhandene ADT und installieren Sie eine neue Version von ADT.generally dieser Probleme auftritt,      wenn Sie SDK aktualisieren mit untenstehenden Link.

https://dl-ssl.google.com/android/eclipse/
2Lalit @

Ich habe dieses Problem gestern gelöst.

Folgen Sie den Schritten : Hilfe -> Neue Software installieren -> Hinzufügen -> ( Geben Sie einen beliebigen Namen annehmen NewUpdate ) -> 'das url: https://dl-ssl.google.com/eclipse/plugin/4.2 -> OK

Jetzt wird es die verfügbaren Updates, die adt 20.xx idealerweise sein sollte Liste

Wählen Sie die Listenelemente Lassen Sie es installiert werden. Eclipse neu starten und Ihre getan .

Ich hoffe, das wird hilfreich für Sie :)

3blue @

Die ADT Bundle auf developer.android.com scheint mir, als veraltet.

Ich reparierte das gleiche Problem durch http://eclipse.org/downloads/ (Java EE war meine Wahl, aber Sie können Ihr Geschmack wählen) und http://developer.android.com/sdk/installing/installing-adt.html

4Rick Falck @

Im Moment habe ich Eclipse und ADT in das gleiche Verzeichnis wie installiert

F:eclipse
    eclipse
    sdk

Ich heruntergeladen und installiert die neueste ADT

C:UsersRickAppDataLocalAndroidandroid-sdk

Ich habe dann kopiert den Inhalt des C:UsersRickAppDataLocalAndroidandroid-sdk in den Ordner F:eclipsesdk, und lassen Sie alle Ordner zusammenführen und überschreiben alles.

Jetzt habe ich 22.6.1 und ich habe nicht erneut herunterladen ganze Plattform Sachen wieder .

5Faruk Toptas @

Ich benutze OS X und vor dem Problem, für 2 Tage . Ich löste das Problem, indem Sie die folgenden Schritte aus :

-Download ADT Bundle aus https://developer.android.com/sdk/index.html -Hilfe -> Neue Software installieren -Write Https://dl-ssl.google.com/android/eclipse/ installieren dann Entwicklertools -restart Eclipse und hob den Fehler im Handumdrehen:

Android SDK content Loader has encountered a problem.parseSdkContent failed
java.lang.NullPointeException

-delete .android Ordner unter Benutzerprofil . Starten Sie eclipse

Keine Fehler und 22.6.1 installiert ist.