Fehlermeldung: Das Android SDK erfordert Android Developer Toolkit Version 22.6.1 oder höher

? kuba @ | Original: StackOverFlow
---

Vor kurzem habe ich folgenden Fehler festgestellt :

Fehlermeldung: Das Android SDK erfordert Android Developer Toolkit Version 22.6.1 oder höher

Das seltsamste ist, dass ich nur einige aktualisierte Paket von sdk über Arbeits Sonnenfinsternis. Es gab keine Informationen oder Warnung, dass nach diesem Update aktuellen adt abstürzen. Ich habe Neueste Inhalte überprüft und können nicht neue adt auch auf Google -Seite zu finden. Auch neue adb enthalten alt adt .

Von http://developer.android.com/tools/sdk/tools-notes.html :

Abhängigkeiten: Android SDK -Plattform - Tools Version 18 oder höher. wenn Sie   entwickeln sich in Eclipse mit ADT, beachten Sie, dass diese Version des SDK   Werkzeuge für die Verwendung mit ADT 22.6.1 und höher entwickelt . Wenn Sie nicht über   bereits, aktualisieren Sie Ihre ADT Plugin 22.6.1 .

Die einzige Lösung ist, dafür zu downloaden neuen Standalone- Sonnenfinsternis und externe Plugins ? Hat das android -Studio die gleichen Probleme ?

Umwelt: Linux x64 .

---

Top 5 Antwort

1beworker @

Ich berichtete https://code.google.com/p/android/issues/detail?id=67325 gestern. Lösung ist, um die Hilfe zu verwenden -> Installieren neuer Software-Option mit https: // Protokoll ( s ist wichtig ) . Keine spezielle Downloads oder Neuinstallationen erforderlich ist, genau die richtige Update- Website zu wählen.

2Robi Kumar Tomar @

Heute ich und einer meiner Freunde vor dem gleichen Problem, so habe ich viele Dinge wie Neustart Sonnenfinsternis, die Überprüfung Updates usw. versucht, aber keines wurde für mich arbeiten .

Dann fand ich eine Lösung von http://developer.android.com/sdk/installing/installing-adt.html und es ist wie ein Charme für mich und auch für meine Freundin arbeitet .

Folgen Sie hier die Schritte :

Start Eclipse, then select Help > Install New Software. Click Add, in the top-right corner.

Im Add Repository Dialog erscheint, geben Sie " ADT Plugin" für die Benennen und die folgende URL für den Standort:

https://dl-ssl.google.com/android/eclipse/

Click OK.

Wenn Sie Probleme beim Erwerb der Plugin, versuchen Sie es mit "http" in der URL Ort statt "https" (https aus Sicherheitsgründen bevorzugt).

In the Available Software dialog, select the checkbox next to Developer Tools and click Next. In the next window, you'll see a list of the tools to be downloaded. Click Next. Read and accept the license agreements, then click Finish. If you get a security warning saying that the authenticity or validity of the software can't be established, click OK. When the installation completes, restart Eclipse. 3TGMCians @

Um dieses Problem zu lösen, hier habe ich überdachte Schritte, doch es wird Ihnen helfen .

Please follow these steps:

Hilfe | Installieren neuer Software

Wählen Sie das ADT -Update-Site (es gibt zwei, eins mit http: // und eine mit https: // Wenn man nicht funktioniert, versuchen Sie das andere .

Wählen Sie das Entwickler-Tools Abschnitt und drücken Sie auf Weiter.

Sie sollten einen Dialog, der sagt, dass " diese Software bereits installiert ist, ein Update durchgeführt werden, anstatt " zu sehen . Durch Klicken auf OK wird auf 22.6.1 führen, dass installiert .

Update 27/03/2014

http://developer.android.com/tools/sdk/eclipse-adt.html#notes

Https://code.google.com/p/android/issues/detail?id=67325 : Sie können diesen Thread zu sehen

4babelsistemas @

Das Problem ist, dass die Standard- Update-Site im Android ADT ist

http://dl-ssl.google.com/android/eclipse/

aber diese Seite nicht korrekt aktualisiert

Und die Lösung ist eine neue Installation vor Ort mit Protokoll https

https://dl-ssl.google.com/android/eclipse/

Klicken Sie im Hilfe-> Install New Software-> hinzufügen

Und die Nutzung dieser Website zu aktualisieren ADT

Ausgabe: https://code.google.com/p/android/issues/detail?id=67325