Jar Missverhältnis ! Befestigen Sie Ihre Abhängigkeiten bei Verwendung appcompat_v7 und Facebook sdk .

? KousiK @ | Original: StackOverFlow
---

Ich bin mit appcompat_v7 Bibliothek und Facebook sdk in meinem Projekt und sowohl die Bibliothek android -support- v4.jar.If ich einen der jar die entsprechende Bibliothek funktioniert nicht löschen und mit beiden Gläsern ist nicht erlaubt.

Was muss ich machen? Bitte helfen Sie mir ...

---

Top 5 Antwort

1Raghunandan @

Der Konflikt ist auf verschiedene Versionen des Glases.

Achten Sie darauf, von der Android- SDK -Manager müssen das Update Support-Bibliothek

Kopieren android-support-v4.jar, um Bibliotheken der beiden Projekte . Das Glas kann gefunden werden @

android-sdk/extras/android/support/v4/andorid-support-v4.jar

Reinigen Sie und erstellen Sie Ihr Projekt

2milapTank @

entfernen android -support- v4.jar von FACEBOOK SDK und fügen android -support- v4.jar als externe jar facebookSDK Eigenschaften -> Java- Build-Pfad -> Bibliotheken -> Add externen jar ( ich hatte dieses Problem wie folgt zu entfernen)

3user2678995 @

Entfernen Sie die Abhängigkeit Bibliothek sowohl appcompat_v7 und Ihr Projekt. Um dies zu tun, die zu path = > configure Build-Pfad bauen bekam . Wählen Sie dann die Abhängigkeit Bibliothek und klicken Sie auf Entfernen . Die Support-Bibliothek hinzufügen, indem Android Extras => Add -Unterstützungsbibliothek . Tun Sie dies, um sowohl projects.Then Sie sind gut zu gehen

4Safdar Akrami @

Es ist wirklich einfach

Einfach Rechtsklick auf das Projekt sowie auf dem Bibliotheksprojekt > Android- Tools > Add Support Bibliothek .

Dies wird Ihre Support-Bibliothek auf die neueste, die das Problem löst aktualisieren.

5Rahul Mandaliya @

Diese Frage ist zu fragen oft, während alle sind Anlauf android Entwicklung in Lernphase . Ich denke, jeder derselben Umgebung von Android hat aber nach Projekten anders konfigurieren.

Ich hatte gleiche Problem beim Erstellen von neuen Projekt jedes Mal, und ich fand Lösung auf unten. Ich fügte hinzu, Bibliothek appcompat_v7 in Projekt und entfernen jar android-support-v4.jar vom Ordner lib mein neues Projekt und blinken ERROR war verschwunden. Add appcompt_v7 Bibliotheksprojekt  Jar Missverhältnis ! Befestigen Sie Ihre Abhängigkeiten bei Verwendung appcompat_v7 und Facebook sdk .

Entfernen android -support- v4.jar aus dem Ordner Projekt lib  Jar Missverhältnis ! Befestigen Sie Ihre Abhängigkeiten bei Verwendung appcompat_v7 und Facebook sdk .

Wow Fehler weg war  Jar Missverhältnis ! Befestigen Sie Ihre Abhängigkeiten bei Verwendung appcompat_v7 und Facebook sdk .