Eclipse- ADT : Projektname " appcompat_v7 ", die nach dem Erstellen jedes neue Projekt erstellt

? uLYsseus @ | Original: StackOverFlow
---

Nun möchte ich diese zu markieren, und bringen sie alle zu diesem Thema, wie der Rest der Themen hatten keine Antwort abgeschlossen, so vor dem Auslassen in sie hier sind die Themen I genannt :

http://stackoverflow.com/questions/22203862/adt-doesnt-create-default-hello-world-but-command-line-does

http://stackoverflow.com/questions/22250633/eclipse-behaving-differently-while-creating-new-project-activity

ADT ist ein bisschen komisch verhalten, da letzten Tagen . Ich halte meine SDK immer aktualisiert, damit ich häufig Führen Sie den SDK -Manager und downloaden Sie alle Updates . vor kurzem habe ich bemerkt, dass, wenn ich ein neues android app -Projekt ist es nicht eine Standard- MainActivity auch wenn ich überprüfen, dass Feld, ist es nicht eine Aktivität unter src und mehr um mich zu ärgern zu erstellen, war ich nicht in der Lage, etwas umgestalten, so wurde mir klar, dass ich mein Eclipse als nach der Lektüre einige Beiträge zu aktualisieren, aber jetzt, wenn ich jedes neues Projekt schafft eine lästige appcompat_v7 Projekt mit jedem Projekt, das sage ich zwei neue Projekte schafft appcompat_v7_2 .... das macht mich verrückt und die neue Projektbibliothek ist die appcompat_v7 Projekt . Dies ist immer ärgerlich und keine Ahnung, was los hier !!!! Was soll ich tun ... Bitte rette mich ! Vielen Dank im Voraus .... Ein Screenshot, um u zu ärgern guys ... :)

Eclipse- ADT : Projektname " appcompat_v7 ", die nach dem Erstellen jedes neue Projekt erstellt

*************** Aktuelle Alternative, keine Lösung ***********************

Ab 2014.12.05 mit ADT 23.0.2 Ich sehe dieses Thema mehr nicht.

I have waited for an acceptable solution on this issue (as of now there is none), but one of the SO members directed me to this post https://code.google.com/p/android/issues/detail?id=66975 . What I am doing is described in one of the solutions below, but for people who have come to this post, the alternative is to delete that ugly project(if you have more than one) which has been created and add up this one(appcompat_v7) as a library. So if you create another project and appcomat_v7_2...comes up delete that and point your project to the appcompat_v7, do the same for other projects too. This is not recommended for some reason though, but it worked well for me till now without issues. If anyone hits up with a solution please post it here. **************** Aktuelle Alternative, keine Lösung *****************************

---

Top 5 Antwort

1user3033613 @

der Ordner appcompat_v7 doesnt erstellt, wenn ich benutze erhalten

minSdkVersion="14"
2shap4th @

Scheint, wie es eine Sonnenfinsternis Bug ist . Was Sie tun müssen, ist zu gehen, um die Eigenschaften in der von der Android -Projekt und in der Android- Section . Fügen Sie die Bibliothek appcompat_v7 und entfernen Sie die appcompat_v_7_2 ( Duplikat) . Dann können Sie die appcompat_v7_2 als Eclipse -Projekt zu entfernen. Alle Fehler behoben.

Nur ein Workaround.

3GPrimola @

Die appcompat Projekt ist eine Bibliothek, um ältere Versionen android unterstützen. Die Support-Bibliothek wurde von Google eingeführt kurzem - ich weiß nicht, in der Android-Version . Aber der Punkt ist, dieses Projekt wird nur dann erstellt, wenn Sie ein Android- Projekt, um Android-Plattformen überqueren erstellen. Ich meine, wenn Sie eine alte min API wählen, beispielsweise API 8 (Froyo ), aber Ziel kurzem Versionen muss das Projekt die Unterstützung Bibliothek. Wie auch immer, die Schaffung appcompat_v7 Projekt einige Frage, die besser durch die Eclipse-Plugin -Maintainer konfiguriert werden muss. Sie können jedoch elegant umdrehen dieses Problem, indem sie auf neuere APIs und auch in den Build-Pfad der Support-Bibliothek . Das ist mehr elegant als die anderen, weil es besser ist, die Sie in nur einer Android-Version konzentrieren, wenn Sie Ihre Anwendung, und wenn es fertig ist, haben Sie eine authentische Version der Anwendung, die Sie als Form verwenden können, um andere Versionen zu unterstützen, entweder ältere oder newers .