Android Studio Gradle Thema Upgrade auf Version 0.5.0 - Gradle Migrieren von 0,8 bis 0,9 - Auch Android Studio Upgrade auf 0.8.1

? Cedric Simon @ | Original: StackOverFlow
---

Nach dem Upgrade Nachricht lautet:

Failed to refresh Gradle project 'XXX'
The project is using an unsupported version of the Android Gradle plug-in (0.8.3).
Version 0.9.0 introduced incompatible changes in the build language.
Please read the migration guide to learn how to update your project.

Gleiche Art von Problem nach dem Upgrade auf Android Studio auf die Version > = 0.8.0

---

Top 5 Antwort

1Cedric Simon @

Um es zu beheben, öffnen Sie die Datei build.gradle im Projektwurzel, und ändern gradle Version gibt es auf 0,9 . + .

buildscript {
    repositories {
        mavenCentral()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:0.9.+'
    }
}

Um für jedes Projekt wiederholt werden ; (

Wenn Sie dann eine Meldung wie " Unable to Klasse zu laden ' org.gradle.api.artifacts.result.ResolvedComponentResult " .

Zum you project_folder/gradle/wrapper Verzeichnis und bearbeiten Unable to load class 'org.gradle.api.artifacts.result.ResolvedComponentResult'. Datei ändern die distributionUrl zu

distributionUrl=http://services.gradle.org/distributions/gradle-1.10-all.zip

Nach dem Upgrade auf Version 0.8.1 ( vollständigen Download und kopieren Sie SDK-Ordner über ), musste eine neue Version von gradle von IDE installiert ( mit "Fix it " verlinken ein paar Mal : S) haben, und modifing die " android " Abschnitt der gradle Datei in Projektordner 19,0-19,1, wie folgt:     Build {         Repositories {             mavenCentral ()         }         Abhängigkeiten {             Klassenpfad ' com.android.tools.build:gradle:0.12.+ '         }     }     Anwendung Plugin : " Android "

repositories {
    mavenCentral()
}

android {
    compileSdkVersion 19
    buildToolsVersion '19.1.0'

    defaultConfig {
        minSdkVersion 7
        targetSdkVersion 19
    }
}

dependencies {
    compile 'com.android.support:appcompat-v7:19.1.+'
    compile 'com.android.support:support-v4:19.1.0'
}
2Gabriele Mariotti @

Android Studio 0.5.0 erfordert gradle - Plugin 0.9.0

Die gradle - Plugin 0.9.0 arbeitet mit Gradle 1.10 oder 1.11 Gradle

Ändern Sie Ihre build.gradle Skript von Cedric vorgeschlagen.

Es gibt eine Beziehung zwischen gradle - Plugin und der gradle Version . zum Beispiel

com.android.tools.build:gradle:0.6.+   -> gradle 1.8
com.android.tools.build:gradle:0.7.+   -> gradle 1.9
com.android.tools.build:gradle:0.8.+   -> gradle 1.9/1.10
com.android.tools.build:gradle:0.9.+   -> gradle 1.10/1.11
com.android.tools.build:gradle:0.10.+  -> gradle 1.10/1.11/1.12
com.android.tools.build:gradle:0.11.+  -> gradle 1.10/1.11/1.12
com.android.tools.build:gradle:0.12.+  -> gradle 1.10/1.11/1.12
com.android.tools.build:gradle:0.13.+  -> gradle 2.1
com.android.tools.build:gradle:0.14.+  -> gradle 2.1
com.android.tools.build:gradle:1.0.+   -> gradle 2.2.1

Sie können gradle Version in Ihrem Projekt in der Datei verwendet finden gradle/wrapper/gradle-wrapper.properties

Auch gibt es eine Beziehung zwischen gradle - Plugin und der IDE -Version. Aktualisiert 2014.08.12 :

Android Studio 0.3.x  -> gradle-plugin 0.6
Android Studio 0.4.x  -> gradle-plugin 0.7
Android Studio 0.4.3+ -> gradle-plugin 0.8
Android Studio 0.5.x  -> gradle-plugin 0.9
Android Studio 0.5.8  -> gradle-plugin 0.9.+ or 0.10.+
Android Studio 0.5.9  -> gradle-plugin 0.9.+ or 0.10.4+
Android Studio 0.6.x  -> gradle-plugin 0.11.+
Android Studio 0.8.x  -> gradle-plugin 0.12.+
Android Studio 0.8.11+  -> gradle-plugin 0.13.+ / gradle-plugin 0.12.+
Android Studio 0.9.x  -> gradle-plugin 0.14.+
Android Studio 1.0.0  -> gradle-plugin 1.0.0

 Also gradle 1.12 requires Android Studio 0.5.8+

Http://tools.android.com/recent : Für aktualisierte Nachrichten finden Sie diesen Link überprüfen

Wenn Sie die Plugin-Version zu ändern, überprüfen Sie die Kompatibilität, und klicken Sie dann auf Sync -Projekt mit Ihrem gradle files.It ein neues Plugin-Version herunterladen, wenn Sie es brauchen.

3pierre renoir @

hmm ich immer diese Fehlermeldung, wenn ich versuche, diese Abhängigkeit hinzuzufügen.

Fehler: (22) ist ein Problem aufgetreten Auswertung Projekt " : App .

Konnte nicht gefunden werden Verfahren Klassenpfad () für Argumente [ com.android.tools.build:gradle:0.9.+ ] am Projekt " : App .

Ok es gelöst . Diese Zeile sollte Teil der build.gradle "im Projekt root" wie oben erwähnt, aber ich nicht kannte. Aktualisierung der Build- Werkzeuge, um 19.03 eigentlich automatisch eingefügt in .

4lucidbrot @

Ich hatte den gleichen Fehler, aber schon

classpath 'com.android.tools.build:gradle:0.9.+'

Set so, als Cedric Simon vorgeschlagen. Dank der Kommentar von mattblang habe ich versucht, es zu ändern, und es 0.9.0 aktualisiert

für diejenigen, die nicht wissen, wo die Schaltfläche Aktualisieren ist, schauen Sie unter :

Android Studio Gradle Thema Upgrade auf Version 0.5.0 - Gradle Migrieren von 0,8 bis 0,9 - Auch Android Studio Upgrade auf 0.8.1

Danach versuchte ich, was passiert, wenn ich wieder auf 0,9 ändern. + Wieder aufzufrischen ... und es funktioniert immer noch .

Also gehe ich davon aus, nur die Taste Refresh-Button genügt hätte .

5codercat @

Die einfachste Android-Projekt hat folgende build.gradle :

buildscript {
    repositories {
        mavenCentral()
    }

    dependencies {
        classpath 'com.android.tools.build:gradle:0.9.0'
    }
}

apply plugin: 'android'

android {
    compileSdkVersion 19
    buildToolsVersion "19.0.0"
}

Es gibt 3 Hauptbereiche dieser Android -Build-Datei :

http://tools.android.com/tech-docs/new-build-system/user-guide