" appcompat_v7 " Projekt wird automatisch nach dem Anlegen eines neuen Projektes in Eclipse erstellt

? Ali @ | Original: StackOverFlow
---

Nachdem Sie alle neuen Android- Projekts erstellt von Eclipse automatisch eine " appcompat_v7 " Projekt ohne Dateien unter / src . Ich habe keine Ahnung, wie oder warum Eclipse das Projekt zu schaffen . Ich bin auch immer eine seltsame Fehler.

" appcompat_v7 " Projekt wird automatisch nach dem Anlegen eines neuen Projektes in Eclipse erstellt

Wie Sie sehen können die AndroidManifest.xml existiert im Projekt !

EDIT 1 : Nach der Reinigung des Projekts die merkwürdige Fehler war weg, aber ich würde noch gerne wissen, warum die appcompat_v7 erstellt wird.

EDIT 2 : Ich habe auch bemerkt, dass Eclipse automatisch ein neues Layout, fragment_main.xml unter / res / layout . WARUM ??

Ich habe einen neuen Arbeitsbereich erstellt, und versuchte es mehrmals. Aber ich habe immer noch dieses Problem.

EDIT3 : Wenn Sie die Mindest SDK-Version nach API 14 wählen Sie nicht diese Unterstützung Ordner zu erhalten.

---

Top 5 Antwort

1maaa @

Ich installierte " Android Unterstützung Repository " von Android SDK Manager / Extras und die Fehler sind weg.

2opus44 @

Ich lief in dieses Problem gestern Abend. Ich habe mehrere Dinge einschließlich der Aktualisierung des SDK -Manager tun . Ich musste wieder aus der Android SDK -Tools, um Rev. 22.3 und Android SDK -Plattform - Tools bis 19 .

opus44

3sony @

erste saubere und bauen die appcompat_v7 Projekt und dann sauber und erstellen Sie Ihr Projekt . es funktioniert

4George Papatheodorou @

importieren Sie die Android- Projekt in den Arbeitsbereich von / Extras / android / support / dann auf das aktuelle Projekt zu navigieren und es als Abhängigkeit hinzu: Projekt> Eigenschaften > Android > Add ( das importierte Projekt). Sie sollten in der Lage, ein grünes Häkchen neben dem importierten Projekt zu sehen. Nehmen Sie die alte Referenz, die Sie verloren / gelöscht. Eine Referenz, was diese Bibliothek zu finden sind https://developer.android.com/tools/support-library/setup.html

5Mokhtarabadi @

Ich auf Ubuntu reinigen nur bis aappcompat_v7 Quellcode es funktionierte gut für mich