Eklipse nicht die Haupttätigkeit und Layout erstellen

? Cookie Monster @ | Original: StackOverFlow
---

Ich kann neue Projekte nicht mehr starten. Das ist, was ich tue ...

Start Eclipse. New Android Application min API 8 target API 18 compile API 19 create activity : checked activity name : MainActivity layout name : activity_main finish

Als ich das Projekt zu öffnen ( es nicht einmal offen MainActivity.java wie es sein sollte ) : - Src -Ordner leer ist - Res / layout Ordner leer

Aber AndroidManifest.xml existiert. Es war perfekt vor der Arbeit und ich war in der Lage, Projekte zu erstellen dann ist es einfach brach plötzlich .

Ich bin mit APIs 18 und 19 alle installiert und auf dem neuesten Stand .

---

Top 5 Antwort

1Adithya @

Ich hatte ein Problem mit dem Öffnen der Layout -Ordner. Ich brauchte eine XML-Datei mit dem Inhalt wie folgt:

<?xml version="1.0" encoding="utf-8"?>
<LinearLayout xmlns:android="http://schemas.android.com/apk/res/android"
xmlns:tools="http://schemas.android.com/tools"
android:layout_width="match_parent"
android:layout_height="match_parent"
android:orientation="horizontal" >
</LinearLayout>

Also, das ist, was ich versucht did.I Aktualisierung Sonnenfinsternis aber, blieb das Problem. Also, habe ich eine neue XML-Datei erstellt nur mit der rechten Maustaste auf das Layout folder.After Erstellen der Datei, ich kopier eingefügt der vorgenannten content.Hope es hilft!

2Toporokis @

Es passiert mir auch. Er hielt plötzlich die Schaffung von MainActivity.java und Layout. Ich konnte es durch die Aktualisierung von Eclipse zu beheben : Hilfe - > Nach Updates suchen -> Alle auswählen

3Werner @

Ich hatte das gleiche Problem gestern nach dem Update die neuesten Pakete auf der Android SDK Manager.

Fest es durch die Aktualisierung der Eclipse-Plugin : Run Eclipse> Help> Install new software> Paste the URL https://dl-ssl.google.com/android/eclipse/ dann drücken Sie Enter . Nach der Aktualisierung der Plugins, habe ich ein Testprojekt mit der Haupttätigkeit und Menü wurde von Standard wie gewohnt erstellt.

4darupa @

Ich hatte auch die gleiche Fehler . Ich reparierte das Problem folgen Werner Empfehlung. Eklipse - > Hilfe - > Installieren neuer Software -> URL eingefügt http://dl-ssl.google.com/android/eclipse/ gedrückt eingeben, aber es ist wichtig, schau es Dir und vor jeder Kopie des Plugin installiert entfernen in Software verfügbar Seiten .

5Dudi72 @

Ich hatte auch das gleiche Problem. Ich reparierte das Problem folgen Werner Empfehlung. Eklipse - > Hilfe - > Installieren neuer Software -> URL eingefügt http://dl-ssl.google.com/android/eclipse/ Es feste mein Problem.