Adt nicht Standard- Welt zu erschaffen, aber hallo Kommandozeile tut

? minttux @ | Original: StackOverFlow
---

Meine ADT korrekt arbeitete als selben wie, was auch immer in Tutorial sah bis vor 2 Tage, als ich erstellt ein Projekt wie vor und auch ich ausgewählt " erstellen Sie eine leere Aktivität" und ich erwarten, dass es einen Standard Hallo Welt -Projekt für mich und ein Main.java auch xML -Layout-Datei, aber es funktioniert nicht diese Standardeinstellung hallo Welt -Projekt zu erstellen mehr. i installiert und die meisten Dinge, aktualisiert in SDK Manager. i erstellt einen anderen Arbeitsbereich, und ich tat, was ich konnte aber nicht standardmäßig Hallo Welt -Projekt zu erstellen . aber wenn ich zu erstellen Projekt von der Kommandozeile es korrekt funktioniert und eine Hallo Welt -Projekt. Warum ADT tut das nicht ? es ist Liste der installierten Paket auf meinem SDK -Manager

Adt nicht Standard- Welt zu erschaffen, aber hallo Kommandozeile tut  Adt nicht Standard- Welt zu erschaffen, aber hallo Kommandozeile tut

und seine der Projektbaum in ADT, die leer ist, wenn ich ein Projekt mit leeren Aktivität :

Adt nicht Standard- Welt zu erschaffen, aber hallo Kommandozeile tut

Aber es funktioniert in Kommandozeile. ich benutze gleichen sdk -Manager von der Kommandozeile :

~/Program/Andr/adt/sdk/tools $ ./android create project --target 24 --name MyFirstApp --path MyFirstApp --activity Main --package com.mrg.myfirstapp
Created project directory: MyFirstApp
....

Und es macht Helloworld -Projekt :

Adt nicht Standard- Welt zu erschaffen, aber hallo Kommandozeile tut

Mein Betriebssystem ist Linux Mint 15-16bit :

$ uname -a
Linux mrg-samsung 3.8.0-19-generic #30-Ubuntu SMP Wed May 1 16:35:23 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Es ist mein Java-Version :

$ java -version
java version "1.7.0_51"
Java(TM) SE Runtime Environment (build 1.7.0_51-b13)
Java HotSpot(TM) 64-Bit Server VM (build 24.51-b03, mixed mode)

und seine meinem ADT Version :

Adt nicht Standard- Welt zu erschaffen, aber hallo Kommandozeile tut

---

Top 5 Antwort

1TGMCians @

As one guy said

Ich hatte das gleiche Problem, obwohl ich heruntergeladen die Android SDK und hat eine saubere Installation, aber ich habe gerade beschlossen sie . Ich habe versucht, klicken Sie auf " Hilfe " -> " Nach Updates suchen " und dann ein Popup- Meldung, alles auf dem neuesten Stand habe ich, aber nach weiterer Forschung schien es mir, es war nicht auf dem neuesten Stand . Was Sie tun müssen, ist klicken Sie auf " Hilfe " -> " Installieren neuer Software " und installieren (dies wird sie zu aktualisieren ) über folgende URL : https://dl-ssl.google.com/android/eclipse/

Sehen Sie hier Faden https://code.google.com/p/android/issues/detail?id=66647

2minttux @

Dieses Problem war, dass der Neue Version des SDK und ADT so zu aktualisieren ADT fügen Sie bitte folgende Adresse ein: https://dl-ssl.google.com/android/eclipse/ ** Beachten Sie, es nicht mit spannenden Adresse arbeiten mit http so gehen, um neue Software installieren in ADT und gehen Sie wie folgt :  Adt nicht Standard- Welt zu erschaffen, aber hallo Kommandozeile tut

Dann wählen Sie diese aus und drücken Sie auf Weiter und Weiter, und akzeptieren Sie die Lizenz und drücken Finish herunterzuladen und zu installieren :  Adt nicht Standard- Welt zu erschaffen, aber hallo Kommandozeile tut

Jetzt nach dem Neustart ADT wenn Sie ein Projekt es wird ein anderes Problem, das ich sah, war der AVD funktioniert nicht richtig arbeiten, erstellen Sie kann nicht neue Gerät, dieses Problem zu führen Sie diesen Befehl aus SDK Pfad lösen hinzuzufügen:

~/Program/android/adt/sdk/tools $ ./android avd

Nachdem fügen Sie Ihre Gerät an ADT und offene AVD gehen von Eclipse, und drücken Sie Aktualisieren  Adt nicht Standard- Welt zu erschaffen, aber hallo Kommandozeile tut

Es sollte jetzt funktionieren

3Shimon Rothschild @

Schritte zu beheben : 1. Eclipse- gehen, um Hilfe / Installieren neuer Software 2. fügen Sie diesen Link . https://dl-ssl.google.com/android/eclipse/ 3. Ich sah zwei Themen " Developer Tools " (5 Beiträge) und NDK Plugins ( 1 Artikel ) 4. Installieren Sie jedes Element einzeln auf Zeit und starten Sie Eclipse 5. Nach der Installation der oben wurde Hallo Welt automatisch mit der zusätzlichen Dateifragmenterstellt.

4dixhom @

Ich traf das gleiche Problem und repariert.

Ich habe die Version der Ziel- SDK von API 21 ( Android L) auf eine andere Version . Es ist einfach das Problem behoben.

5g_brahimaj @

Ich hatte das gleiche Problem, aber es würde nicht reparieren, weil ich die neuesten Updates bereits . Nach stundenlangem Such die einzige Möglichkeit der Befestigung es um eine neue Kopie von Eclipse herunterladen und erstellen Sie einen neuen Arbeitsbereich . Über die Schritte, die minttux angegeben wurde. Ich hoffe, es hilft bei den neueren Versionen von Eclipse .