wenn ich nehme neue Android- Projekt appcompt Fehler anzeigt wird

? Rohit Bandil @ | Original: StackOverFlow

vor diesem Fehler meiner all -Anwendung gehen gut, aber wenn ich nahm neues Projekt plötzlich zeigt Fehler in meinem appcompat und in meinem Projekt in Build-Pfad in Abhängigkeit android es zeigt error.Pleas geben Sie mir einige Lösung, was soll ich tun . und gib mir mehr Klarheit android Abhängigkeit und AppCompat Bibliotheksdatei . es zeigt diese Fehlermeldung: -

appcompat_v7/res/values-v21/themes_base.xml:194: error: Error: No resource found that matches the given name: attr 'android:colorControlActivated'.
appcompat_v7/res/values-v21/themes_base.xml:195: error: Error: No resource found that matches the given name: attr 'android:colorControlHighlight'.
appcompat_v7/res/values-v21/themes_base.xml:193: error: Error: No resource found that matches the given name: attr 'android:colorControlNormal'.
appcompat_v7/res/values-v21/themes_base.xml:190: error: Error: No resource found that matches the given name: attr 'android:colorPrimary'.
appcompat_v7/res/values-v21/themes_base.xml:191: error: Error: No resource found that matches the given name: attr 'android:colorPrimaryDark'.

thanks



Top 5 Antwort

1user3173628 @

Sie nicht richtig aufgenommen haben die appcompat_v7 Bibliothek

prüfen, ob Sie die Bibliothek in der rechten klicken Sie mit der Projekt- > Eigenschaften-> wählen Android- > appcompact lib ( diese Bibliothek sollte verwiesen werden Sie diese eine fehlt) So gehen Sie vor: -

1) mit der rechten Maustaste auf Ihr Projekt, und wählen Sie Eigenschaften.

2) In der Kategorie auf der linken Seite des Dialogs die Option Android .

3) im Bereich Bibliothek, klicken Sie auf die Schaltfläche Hinzufügen.

4) Wählen Sie die Bibliothek -Projekt und klicken Sie auf OK . Zum Beispiel sollte die appcompat Projekt als android -support- v7 - appcompat aufgelistet.

5) im Eigenschaftenfenster, klicken Sie auf OK .

Wenn Sie nichts sehen, wenn Sie klicken (Schritt 3) hinzufügen, dann sollten Sie diesem Link beziehen : - https://developer.android.com/tools/support-library/setup.html in diesem Link lesen Hinzufügen Bibliotheken mit Ressourcen und die Folgen Sie den Anweisungen .

OR

Make sure you have downloaded the Android Support Library using the SDK Manager.
Create a library project and ensure the required JAR files are included in the project's build path:
   1) Select File > Import.

    2)Select Existing Android Code Into Workspace and click Next.
    Browse to the SDK installation directory and then to the Support Library folder. 
    For example, if you are adding the appcompat project, 
    browse to <sdk>/extras/android/support/v7/appcompat/.

    3)Click Finish to import the project. For the v7 appcompat project,
   you should now see a new project titled android-support-v7-appcompat.

   4)  In the new library project, expand the libs/ folder,
   right-click each .jar file and select Build Path > Add to Build Path. 
   For example, when creating the the v7 appcompat project, 
   add both the android-support-v4.jar and android-support-v7-appcompat.jar files to the build path.
   5) Right-click the library project folder and select Build Path > Configure Build  Path.

    6) In the Order and Export tab, check the .jar files you just added to the build path, so they are available to projects that depend on this library project. For example, the appcompat project requires you to export both the android-support-v4.jar and android-support-v7-appcompat.jar files.
    Uncheck Android Dependencies.
   7) Click OK to complete the changes.
2Rohit Bandil @

endlich meine Fehler solveed aber das ist nicht genau die Lösung, was ich wollte . was ich tat, ich habe ein neues Projekt angelegt und nahm min sdk -Version ist 15 bcoz Aktionsleiste Feature ist in 15 Gegenwart und weitere api .Ich denke, dass Funktion in 11 api .so ich habe neues Projekt mit min sdk -Version und dann entnommen eingeführt kein bedürftig AppCompat Bibliothek jetzt ist kein Fehler kommt ... aber ich löste dieses Problem, indem alternative Lösung, aber ich möchte auch Antwort auf Ihre Frage .

3Naveed @

Ja, das Ding war mir auch da zu Tage kommen . Gehen Sie zu Ihrem Projekteigenschaften und wählen Sie die Android- API -Version, die alle Dinge mit Ihnen in sdk zum Beispiel in meinem Fall api 17 Ich wähle heruntergeladen und in sdk Ich habe alles installiert .  wenn ich nehme neue Android- Projekt appcompt Fehler anzeigt wird

Ich habe auch eine Sache besonders in (Bild) unten können Sie das Kontrollkästchen ( Ist Library) sehen Ich entfernte die refrence appcompat_v7 und klicken Sie auf Übernehmen.

Nach dieser every mit mir zu arbeiten wie Charme ..... Endlich komme ich zu dem Punkt,