Haben Sie einen Fehler beim Erstellen eines Projekts in neuen Arbeitsbereich

? Harikrishnan @ | Original: StackOverFlow

Bin für Android Entwicklung. Ich habe versucht, einen neuen Arbeitsbereich mit Ziel SDK API 21 zu erstellen und mit API 19. Ich habe das SDK von API19 und 20 und nicht die Android5 installiert zusammengestellt . Ich habe einen neuen Arbeitsbereich und ein neues Projekt, bei dem ich am Ende mit der folgenden Fehler beim Kompilieren des Projekts nach der Erstellung . Kann jemand mir helfen, wie man das beheben ?

Error details:

Top 5 Antwort

1QArea @

Haben Sie Build-Ziel des Projekts zu Android 4.4.2 zu ändern?

Hier Jungs hatten das gleiche Problem : http://stackoverflow.com/a/14843198/3864698

2Muhammad Ebad @

Ein Staubbeutel, was Sie versuchen können, ist, den project.properties Datei des android -support- v7 - appcompat öffnen und die Ziel Ziel . Und dann einfach eine Projekt -> Reinigen Sie damit die Änderungen wirksam werden.

3Andy Dent @

Ich habe einen ähnlichen Fehler wie jemand neu in der Installation von Android Tools und nachdem versehentlich ausgewählt die 4.4W sowie 4.4.2 im Android SDK Manager.

Daraus ergibt sich, die sowohl API 20 API und 19 installiert, was bedeutet, API 20 scheint neuere zu sein, und wird standardmäßig für neue Projekte aufgenommen werden .

, API 20 ist jedoch nur Wearables .

Sie können hier in Haben Sie einen Fehler beim Erstellen eines Projekts in neuen Arbeitsbereich, dass 4,4 W hat in den Weg beendet sehen .

Sowohl die appcompat_v7 und HelloAndy Projektziele hatte diesen Weg Problem.

Ich bearbeitete project.properties für beide und verändert target = android -20 zum Ziel = android -19 tat dann eine Aktualisierung auf beiden Projekte ( Rechtsklick auf die appcompat_v7 und anderen Projekt). Das aktualisiert die Build- Wege, um zum richtigen Android SDK verweisen.

4pokerface @

Aktualisieren Sie die Datei von project.properties AppCompat v7, die hat : target=android-19 auf target=android-21

Auch aktualisieren google play services Bibliothek ( durch update Ich meine, aktualisieren Sie es in SDK Manager und Re-Import usw.)

5Adgaonker Shashank @

Entfernen Sie einfach diesen Stil Linie wohin Fehler gefunden wird, dann reinigen Sie Ihr Projekt

und stellen Sie Ihr Projekt 5.0 setted